summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1e1013e6dc..068c15c0db 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,6 +24,22 @@ dist-rpm: dist
mv $$RPM_BUILD_DIR/RPMS/*/* .; \
rm -rf $$RPM_BUILD_DIR
+dist-osx:
+ @if [ "x$(prefix)" != 'x/Library/Tor' ]; then \
+ echo "Configure with --prefix=/Library/Tor, please"; \
+ exit 1; \
+ fi; \
+ if [ "x$(bindir)" != 'x/Library/Tor' ]; then \
+ echo "Configure with --bindir=/Library/Tor, please"; \
+ exit 1; \
+ fi; \
+ if [ "x$(sysconfdir)" != 'x/Library' ]; then \
+ echo "Configure with --sysconfdir=/Library, please"; \
+ exit 1; \
+ fi
+ $(MAKE) all
+ VERSION=$(VERSION) sh ./contrib/osx/package.sh
+
doxygen:
doxygen && cd doc/doxygen/latex && make