aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 8 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 92ba2b868d..3c802900a0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,9 +19,9 @@ AM_CFLAGS = @TOR_SYSTEMD_CFLAGS@
SHELL = @SHELL@
if COVERAGE_ENABLED
-TESTING_TOR_BINARY="$(top_builddir)/src/or/tor-cov"
+TESTING_TOR_BINARY=$(top_builddir)/src/or/tor-cov$(EXEEXT)
else
-TESTING_TOR_BINARY="$(top_builddir)/src/or/tor"
+TESTING_TOR_BINARY=$(top_builddir)/src/or/tor$(EXEEXT)
endif
include src/include.am
@@ -93,7 +93,7 @@ need-chutney-path:
# Note that test-network requires a copy of Chutney in $CHUTNEY_PATH.
# Chutney can be cloned from https://git.torproject.org/chutney.git .
-test-network: need-chutney-path all
+test-network: need-chutney-path $(TESTING_TOR_BINARY) src/tools/tor-gencert
$(top_srcdir)/src/test/test-network.sh $(TEST_NETWORK_FLAGS)
# Run all available tests using automake's test-driver
@@ -101,7 +101,7 @@ test-network: need-chutney-path all
# some IPv6 tests will fail without an IPv6 DNS server (see #16971 and #17011)
# only run mixed tests if we have a tor-stable binary
# see #17015 for autodetection of different tor versions
-test-network-all: need-chutney-path all test-driver
+test-network-all: need-chutney-path test-driver $(TESTING_TOR_BINARY) src/tools/tor-gencert
mkdir -p $(TEST_NETWORK_ALL_LOG_DIR)
@flavors="$(TEST_CHUTNEY_FLAVORS)"; \
if ping6 -q -o ::1 >/dev/null 2>&1; then \
@@ -134,11 +134,11 @@ need-stem-path:
exit 1; \
fi
-test-stem: need-stem-path all
- @$(PYTHON) "$$STEM_SOURCE_DIR"/run_tests.py --tor $(TESTING_TOR_BINARY) --all --log notice --target RUN_ALL;
+test-stem: need-stem-path $(TESTING_TOR_BINARY)
+ @$(PYTHON) "$$STEM_SOURCE_DIR"/run_tests.py --tor "$(TESTING_TOR_BINARY)" --all --log notice --target RUN_ALL;
-test-stem-full: need-stem-path all
- @$(PYTHON) "$$STEM_SOURCE_DIR"/run_tests.py --tor $(TESTING_TOR_BINARY) --all --log notice --target RUN_ALL,ONLINE -v;
+test-stem-full: need-stem-path $(TESTING_TOR_BINARY)
+ @$(PYTHON) "$$STEM_SOURCE_DIR"/run_tests.py --tor "$(TESTING_TOR_BINARY)" --all --log notice --target RUN_ALL,ONLINE -v;
test-full: need-stem-path need-chutney-path check test-network test-stem