summaryrefslogtreecommitdiff
path: root/src/tools/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2007-05-01 02:53:32 +0000
committerNick Mathewson <nickm@torproject.org>2007-05-01 02:53:32 +0000
commit8f94f0540fc4a1c5526d091fff955a5cdbdc9293 (patch)
treecd1e9862aa0a9cff4828929d6299c777146aa459 /src/tools/Makefile.am
parentd5a23f38df7d7ebda0995a04e449a8e0a6173518 (diff)
downloadtor-8f94f0540fc4a1c5526d091fff955a5cdbdc9293.tar.gz
tor-8f94f0540fc4a1c5526d091fff955a5cdbdc9293.zip
r12611@catbus: nickm | 2007-04-30 22:49:00 -0400
For reasons which make sense to somebody, I'm sure, mingw gcc wants the libraries to appear at the end of the command line. This is done by specifying them with LDADD in Makefile.am, not LDFLAGS. If anybody can explain to me why mingw thinks "gcc -o foo foo.o -lbar" is fine, whereas "gcc -lbar -o foo foo.o" is Doubleplusbad UnMingwThink, I'd quite appreciate it. Until then, I'll just do what seems to work, and hope we don't blunder across any other great slumbering cthonian deities of arbitrary syntax. svn:r10082
Diffstat (limited to 'src/tools/Makefile.am')
-rw-r--r--src/tools/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/src/tools/Makefile.am b/src/tools/Makefile.am
index 6d256a54a6..7d7f2c7b8f 100644
--- a/src/tools/Makefile.am
+++ b/src/tools/Makefile.am
@@ -1,11 +1,12 @@
bin_PROGRAMS = tor-resolve tor-gencert
tor_resolve_SOURCES = tor-resolve.c
-tor_resolve_LDFLAGS = @TOR_LDFLAGS_libevent@ -levent @TOR_LIB_WS32@
-tor_resolve_LDADD = ../common/libor.a
+tor_resolve_LDFLAGS = @TOR_LDFLAGS_libevent@
+tor_resolve_LDADD = ../common/libor.a -levent @TOR_LIB_WS32@
tor_gencert_SOURCES = tor-gencert.c
tor_gencert_LDFLAGS = @TOR_LDFLAGS_zlib@ @TOR_LDFLAGS_openssl@ \
- @TOR_LDFLAGS_libevent@ -lz -lcrypto -levent \
- @TOR_LIB_WS32@ @TOR_LIB_GDI@
-tor_gencert_LDADD = ../common/libor.a ../common/libor-crypto.a
+ @TOR_LDFLAGS_libevent@
+tor_gencert_LDADD = ../common/libor.a ../common/libor-crypto.a \
+ -lz -lcrypto -levent @TOR_LIB_WS32@ @TOR_LIB_GDI@
+