summaryrefslogtreecommitdiff
path: root/src/rust/tor_util/Cargo.toml
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-09-16 14:34:31 -0400
committerNick Mathewson <nickm@torproject.org>2018-09-16 14:34:31 -0400
commita8ac21fbb5f22b68ffa019b575085c142293bc40 (patch)
treee32e8574612eba971173c5513bd57eae9162bce3 /src/rust/tor_util/Cargo.toml
parent078debb0ded16e7f8d79d5aa6f4184ae5ad44ff9 (diff)
downloadtor-a8ac21fbb5f22b68ffa019b575085c142293bc40.tar.gz
tor-a8ac21fbb5f22b68ffa019b575085c142293bc40.zip
Don't try to link C from rust doctests for nss detection
This is really annoying, since we can't use cfg(test) for doctests.
Diffstat (limited to 'src/rust/tor_util/Cargo.toml')
-rw-r--r--src/rust/tor_util/Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/rust/tor_util/Cargo.toml b/src/rust/tor_util/Cargo.toml
index a606a280b2..51e4bd9c5d 100644
--- a/src/rust/tor_util/Cargo.toml
+++ b/src/rust/tor_util/Cargo.toml
@@ -17,3 +17,9 @@ path = "../tor_log"
[dependencies]
libc = "=0.2.39"
+[features]
+# We have to define a feature here because doctests don't get cfg(test),
+# and we need to disable some C dependencies when running the doctests
+# because of the various linker issues. See
+# https://github.com/rust-lang/rust/issues/45599
+test_linking_hack = []