aboutsummaryrefslogtreecommitdiff
path: root/src/rust/tor_rust/Cargo.toml
diff options
context:
space:
mode:
authorAlex Crichton <alex@alexcrichton.com>2018-10-01 22:58:44 -0700
committerAlex Crichton <alex@alexcrichton.com>2018-10-01 22:58:44 -0700
commit38d644c94bf1a42fcec40843e817c460e9e752de (patch)
tree591fb21c58ccdacc26c391d6ad28cf5737636c91 /src/rust/tor_rust/Cargo.toml
parent757a2360a41a5de2abd283ddee9fd26bb045bc04 (diff)
downloadtor-38d644c94bf1a42fcec40843e817c460e9e752de.tar.gz
tor-38d644c94bf1a42fcec40843e817c460e9e752de.zip
Remove rlib+staticlib configuration for Rust crates
Only the final crate needs to be a `staticlib`, no need for all the intermediate steps to produce staticlibs!
Diffstat (limited to 'src/rust/tor_rust/Cargo.toml')
-rw-r--r--src/rust/tor_rust/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/rust/tor_rust/Cargo.toml b/src/rust/tor_rust/Cargo.toml
index 1523ee0dd1..35c629882e 100644
--- a/src/rust/tor_rust/Cargo.toml
+++ b/src/rust/tor_rust/Cargo.toml
@@ -6,7 +6,7 @@ version = "0.1.0"
[lib]
name = "tor_rust"
path = "lib.rs"
-crate_type = ["rlib", "staticlib"]
+crate_type = ["staticlib"]
[dependencies.tor_util]
path = "../tor_util"