summaryrefslogtreecommitdiff
path: root/src/rust/smartlist/Cargo.toml
diff options
context:
space:
mode:
authorDavid Goulet <dgoulet@torproject.org>2021-09-14 11:03:00 -0400
committerDavid Goulet <dgoulet@torproject.org>2021-10-06 15:12:04 -0400
commitae9042abbfbd9b854fe46138e62cc0b3f6696b68 (patch)
treeca7d06040a74d77e26562bbc1d209a462d59351f /src/rust/smartlist/Cargo.toml
parentc3e50f0fde701c01d68ebea60e8b9e978937a201 (diff)
downloadtor-ae9042abbfbd9b854fe46138e62cc0b3f6696b68.tar.gz
tor-ae9042abbfbd9b854fe46138e62cc0b3f6696b68.zip
rust: Remove Rust support from tree
Closes #40469 Signed-off-by: David Goulet <dgoulet@torproject.org>
Diffstat (limited to 'src/rust/smartlist/Cargo.toml')
-rw-r--r--src/rust/smartlist/Cargo.toml18
1 files changed, 0 insertions, 18 deletions
diff --git a/src/rust/smartlist/Cargo.toml b/src/rust/smartlist/Cargo.toml
deleted file mode 100644
index a5afe7bf74..0000000000
--- a/src/rust/smartlist/Cargo.toml
+++ /dev/null
@@ -1,18 +0,0 @@
-[package]
-authors = ["The Tor Project"]
-version = "0.0.1"
-name = "smartlist"
-
-[dependencies]
-libc = "0.2.39"
-
-[lib]
-name = "smartlist"
-path = "lib.rs"
-
-[features]
-# We have to define a feature here because doctests don't get cfg(test),
-# and we need to disable some C dependencies when running the doctests
-# because of the various linker issues. See
-# https://github.com/rust-lang/rust/issues/45599
-test_linking_hack = []