summaryrefslogtreecommitdiff
path: root/src/rust/rand/Cargo.toml
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-05-03 13:50:18 -0400
committerNick Mathewson <nickm@torproject.org>2018-05-03 13:50:18 -0400
commitc3b72583709332f051fb61e17f5102d0ada05917 (patch)
treea686097afdcda0074eb00d7b6e667abf91dc19e5 /src/rust/rand/Cargo.toml
parent94c6eb7d7f023e50071632e618f003409e5e6489 (diff)
parent94dcd38a1430061a0bb630ad680a41a78262a55c (diff)
downloadtor-c3b72583709332f051fb61e17f5102d0ada05917.tar.gz
tor-c3b72583709332f051fb61e17f5102d0ada05917.zip
Merge remote-tracking branch 'isis/bug24660_r1'
Diffstat (limited to 'src/rust/rand/Cargo.toml')
-rw-r--r--src/rust/rand/Cargo.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/rust/rand/Cargo.toml b/src/rust/rand/Cargo.toml
new file mode 100644
index 0000000000..1b73563c8d
--- /dev/null
+++ b/src/rust/rand/Cargo.toml
@@ -0,0 +1,27 @@
+# TODO: Note that this package should be merged into the "crypto" crate after #24659 is merged.
+
+[package]
+authors = ["The Tor Project"]
+version = "0.0.1"
+name = "rand"
+publish = false
+
+[features]
+testing = ["tor_log/testing"]
+
+[dependencies]
+libc = "=0.2.39"
+rand_core = "=0.1.0"
+
+external = { path = "../external" }
+tor_allocate = { path = "../tor_allocate" }
+tor_log = { path = "../tor_log" }
+tor_util = { path = "../tor_util" }
+
+[dev-dependencies]
+rand = { version = "=0.5.0-pre.0", default-features = false, path = "../../ext/rust/vendor/rand-8c5b0ac51d" }
+
+[lib]
+name = "rand"
+path = "lib.rs"
+crate_type = ["rlib", "staticlib"]