summaryrefslogtreecommitdiff
path: root/src/rust/crypto/Cargo.toml
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-05-16 09:16:04 -0400
committerNick Mathewson <nickm@torproject.org>2018-05-16 09:16:04 -0400
commit1442e818b67561c810c5d18894e29c57f8fdbbb0 (patch)
tree3bf8127f1a60a330df405df22e4ed0b1e9e2fc07 /src/rust/crypto/Cargo.toml
parente5974e51589e5d16aa4f518c86abac1f43f55e5a (diff)
parent4d349c6a6124b8d94dc787f0076c15b896272363 (diff)
downloadtor-1442e818b67561c810c5d18894e29c57f8fdbbb0.tar.gz
tor-1442e818b67561c810c5d18894e29c57f8fdbbb0.zip
Merge remote-tracking branch 'isis-github/bug26106'
Diffstat (limited to 'src/rust/crypto/Cargo.toml')
-rw-r--r--src/rust/crypto/Cargo.toml15
1 files changed, 11 insertions, 4 deletions
diff --git a/src/rust/crypto/Cargo.toml b/src/rust/crypto/Cargo.toml
index e6a8bffa27..3d343344ae 100644
--- a/src/rust/crypto/Cargo.toml
+++ b/src/rust/crypto/Cargo.toml
@@ -13,9 +13,16 @@ crate_type = ["rlib", "staticlib"]
[dependencies]
libc = "=0.2.39"
digest = "=0.7.2"
+rand_core = "=0.2.0-pre.0"
-[dependencies.external]
-path = "../external"
+external = { path = "../external" }
+smartlist = { path = "../smartlist" }
+tor_allocate = { path = "../tor_allocate" }
+tor_log = { path = "../tor_log" }
+
+[dev-dependencies]
+rand = { version = "=0.5.0-pre.2", default-features = false }
+
+[features]
+testing = ["tor_log/testing"]
-[dependencies.smartlist]
-path = "../smartlist"