summaryrefslogtreecommitdiff
path: root/src/or/Makefile.am
diff options
context:
space:
mode:
authorGeorge Kadianakis <desnacked@gmail.com>2010-12-01 03:32:42 +0200
committerNick Mathewson <nickm@torproject.org>2011-02-22 12:40:38 -0500
commitee95430d397d2382227cdeac8c678c7345df594d (patch)
treef946eeac09e632650c1b038ce6a203c4ab194a6d /src/or/Makefile.am
parent098b6ba72d636cf00cfa091e745c25a649fba493 (diff)
downloadtor-ee95430d397d2382227cdeac8c678c7345df594d.tar.gz
tor-ee95430d397d2382227cdeac8c678c7345df594d.zip
Implement more heartbeat message stuff.
(This squashes multiple commits: * Adds uptime monitoring support. * Adds circuit counting code. * Trivially tweaks the documentation. * Trivial run_scheduled_events() code tweaking. * Adds a status.h to export functions. * Added bandwidth monitoring code. * Added consensus presense detection code. * Restricts the precision of the bandwidth output. * Various fixes. * Fixed style and spacing problems. * Tidied up src/or/Makefile.am * Couple of minor fixes on status.c functions. * 'Implemented' client heartbeat support )
Diffstat (limited to 'src/or/Makefile.am')
-rw-r--r--src/or/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/src/or/Makefile.am b/src/or/Makefile.am
index a49a86a607..f0d5a0f5f9 100644
--- a/src/or/Makefile.am
+++ b/src/or/Makefile.am
@@ -50,10 +50,10 @@ libtor_a_SOURCES = \
router.c \
routerlist.c \
routerparse.c \
+ status.c \
$(evdns_source) \
$(tor_platform_source) \
- config_codedigest.c \
- status.c
+ config_codedigest.c
#libtor_a_LIBADD = ../common/libor.a ../common/libor-crypto.a \
# ../common/libor-event.a
@@ -120,7 +120,8 @@ noinst_HEADERS = \
router.h \
routerlist.h \
routerparse.h \
- micro-revision.i
+ status.h \
+ micro-revision.i
config_codedigest.o: or_sha1.i