summaryrefslogtreecommitdiff
path: root/src/or/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2006-06-03 19:49:42 +0000
committerNick Mathewson <nickm@torproject.org>2006-06-03 19:49:42 +0000
commit7cb3232ade9c55d26a64bddbd12a92a2a32180cd (patch)
tree97a779a7a4d360f8b06f1d255cd75fa676339820 /src/or/Makefile.am
parent86da3e0a0af5813d6f5eb695d8353b2988f256ff (diff)
downloadtor-7cb3232ade9c55d26a64bddbd12a92a2a32180cd.tar.gz
tor-7cb3232ade9c55d26a64bddbd12a92a2a32180cd.zip
Add async dns code from Adam Langley, tweaked to build on OSX. Long-term, we may want to switch to libevnet/c-ares, if they ever handle 10k fd situations properly. This one still needs work too, but at least it is small. This code is disabled by default, and not integrated with dns.c.
svn:r6524
Diffstat (limited to 'src/or/Makefile.am')
-rw-r--r--src/or/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/or/Makefile.am b/src/or/Makefile.am
index 6a77adffaa..b5014ba800 100644
--- a/src/or/Makefile.am
+++ b/src/or/Makefile.am
@@ -4,12 +4,19 @@ noinst_PROGRAMS = test
bin_PROGRAMS = tor
+if EVENTDNS
+EVDNSSRC = eventdns.c
+else
+EVDNSSRC =
+endif
+
tor_SOURCES = buffers.c circuitbuild.c circuitlist.c \
circuituse.c command.c config.c \
connection.c connection_edge.c connection_or.c control.c \
cpuworker.c directory.c dirserv.c dns.c hibernate.c main.c \
onion.c policies.c relay.c rendcommon.c rendclient.c rendmid.c \
rendservice.c rephist.c router.c routerlist.c routerparse.c \
+ $(EVDNSSRC) \
tor_main.c
tor_LDADD = ../common/libor.a ../common/libor-crypto.a -lz -lssl -lcrypto
@@ -20,6 +27,7 @@ test_SOURCES = buffers.c circuitbuild.c circuitlist.c \
cpuworker.c directory.c dirserv.c dns.c hibernate.c main.c \
onion.c policies.c relay.c rendcommon.c rendclient.c rendmid.c \
rendservice.c rephist.c router.c routerlist.c routerparse.c \
+ $(EVDNSSRC) \
test.c
test_LDADD = ../common/libor.a ../common/libor-crypto.a -lz -lssl -lcrypto