summaryrefslogtreecommitdiff
path: root/src/or/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2007-04-30 20:50:09 +0000
committerNick Mathewson <nickm@torproject.org>2007-04-30 20:50:09 +0000
commit22f2f30a33d0fa525730f2915f9d7209bd0045fe (patch)
treeefd9b9f713414586b51b9f09015fe589945c74b5 /src/or/Makefile.am
parente97a6dd01f76f5380d80a1b6061abd0b583a7aab (diff)
downloadtor-22f2f30a33d0fa525730f2915f9d7209bd0045fe.tar.gz
tor-22f2f30a33d0fa525730f2915f9d7209bd0045fe.zip
r12591@catbus: nickm | 2007-04-30 16:50:03 -0400
Minimize the libraries that we link things against: there is no reason to link tor-resolve against zlib, openssl, or libevent, for example. svn:r10072
Diffstat (limited to 'src/or/Makefile.am')
-rw-r--r--src/or/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/or/Makefile.am b/src/or/Makefile.am
index ef079a45c1..93f9edb198 100644
--- a/src/or/Makefile.am
+++ b/src/or/Makefile.am
@@ -13,6 +13,9 @@ tor_SOURCES = buffers.c circuitbuild.c circuitlist.c \
eventdns.c \
tor_main.c
+tor_LIBS = -lz -levent -lssl -lcrypto
+tor_LDFLAGS = @TOR_LDFLAGS_zlib@ @TOR_LDFLAGS_openssl@ @TOR_LDFLAGS_libevent@ \
+ -lz -levent -lssl -lcrypto
tor_LDADD = ../common/libor.a ../common/libor-crypto.a
test_SOURCES = buffers.c circuitbuild.c circuitlist.c \
@@ -24,6 +27,8 @@ test_SOURCES = buffers.c circuitbuild.c circuitlist.c \
eventdns.c \
test.c
+test_LDFLAGS = @TOR_LDFLAGS_zlib@ @TOR_LDFLAGS_openssl@ \
+ @TOR_LDFLAGS_libevent@ -lz -levent -lssl -lcrypto
test_LDADD = ../common/libor.a ../common/libor-crypto.a
noinst_HEADERS = or.h eventdns.h eventdns_tor.h micro-revision.i