summaryrefslogtreecommitdiff
path: root/src/or/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2007-03-05 02:40:58 +0000
committerNick Mathewson <nickm@torproject.org>2007-03-05 02:40:58 +0000
commit52713788b4dfafd7c07733f037e64bf2fec14ea1 (patch)
treece508592312f80d17c759974d680e319c19ee60b /src/or/Makefile.am
parent92f62b36846e3c82f5521fa17f7a4f5afde827af (diff)
downloadtor-52713788b4dfafd7c07733f037e64bf2fec14ea1.tar.gz
tor-52713788b4dfafd7c07733f037e64bf2fec14ea1.zip
r12080@catbus: nickm | 2007-03-04 21:40:55 -0500
Remove dnsworkers and related code. there goes another 550 lines of code. svn:r9736
Diffstat (limited to 'src/or/Makefile.am')
-rw-r--r--src/or/Makefile.am12
1 files changed, 3 insertions, 9 deletions
diff --git a/src/or/Makefile.am b/src/or/Makefile.am
index 91ec1c057c..bf27e4d2cb 100644
--- a/src/or/Makefile.am
+++ b/src/or/Makefile.am
@@ -4,19 +4,13 @@ noinst_PROGRAMS = test
bin_PROGRAMS = tor
-if EVENTDNS
-EVDNSSRC = eventdns.c
-else
-EVDNSSRC =
-endif
-
tor_SOURCES = buffers.c circuitbuild.c circuitlist.c \
circuituse.c command.c config.c \
connection.c connection_edge.c connection_or.c control.c \
cpuworker.c directory.c dirserv.c dns.c hibernate.c main.c \
onion.c policies.c relay.c rendcommon.c rendclient.c rendmid.c \
rendservice.c rephist.c router.c routerlist.c routerparse.c \
- $(EVDNSSRC) \
+ eventdns.c \
tor_main.c
tor_LDADD = ../common/libor.a ../common/libor-crypto.a -lz -lssl -lcrypto
@@ -27,10 +21,10 @@ test_SOURCES = buffers.c circuitbuild.c circuitlist.c \
cpuworker.c directory.c dirserv.c dns.c hibernate.c main.c \
onion.c policies.c relay.c rendcommon.c rendclient.c rendmid.c \
rendservice.c rephist.c router.c routerlist.c routerparse.c \
- $(EVDNSSRC) \
+ eventdns.c \
test.c
test_LDADD = ../common/libor.a ../common/libor-crypto.a -lz -lssl -lcrypto
-noinst_HEADERS = or.h eventdns.h eventdns_tor.h eventdns.c
+noinst_HEADERS = or.h eventdns.h eventdns_tor.h