summaryrefslogtreecommitdiff
path: root/src/or/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2004-10-30 19:27:06 +0000
committerNick Mathewson <nickm@torproject.org>2004-10-30 19:27:06 +0000
commitae7495dd55e0e3346e1e18eefbe6aa95dc6fdf33 (patch)
tree026065d1a349adfa7e8b9cd423e06b8880b5cd5a /src/or/Makefile.am
parent5bc0dba9338c6722f6833351b1401571533eb63d (diff)
downloadtor-ae7495dd55e0e3346e1e18eefbe6aa95dc6fdf33.tar.gz
tor-ae7495dd55e0e3346e1e18eefbe6aa95dc6fdf33.zip
Only tor and test binaries need to link against openssl and zlib; tor-resolve can be smaller.
svn:r2629
Diffstat (limited to 'src/or/Makefile.am')
-rw-r--r--src/or/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/or/Makefile.am b/src/or/Makefile.am
index a1b956b4aa..edbb4c8653 100644
--- a/src/or/Makefile.am
+++ b/src/or/Makefile.am
@@ -12,7 +12,7 @@ tor_SOURCES = buffers.c circuitbuild.c circuitlist.c \
rendservice.c rephist.c router.c routerlist.c routerparse.c \
tor_main.c
-tor_LDADD = ../common/libor.a -lz
+tor_LDADD = ../common/libor.a ../common/libor-crypto.a -lz -lssl -lcrypto
test_SOURCES = buffers.c circuitbuild.c circuitlist.c \
circuituse.c command.c config.c \
@@ -22,7 +22,7 @@ test_SOURCES = buffers.c circuitbuild.c circuitlist.c \
rendservice.c rephist.c router.c routerlist.c routerparse.c \
test.c
-test_LDADD = ../common/libor.a -lz
+test_LDADD = ../common/libor.a ../common/libor-crypto.a -lz -lssl -lcrypto
noinst_HEADERS = or.h tree.h