summaryrefslogtreecommitdiff
path: root/src/or/Makefile.am
diff options
context:
space:
mode:
authorRoger Dingledine <arma@torproject.org>2004-04-02 22:23:15 +0000
committerRoger Dingledine <arma@torproject.org>2004-04-02 22:23:15 +0000
commitf34e6da3e75ad5b681c68e6c0a50d65d4566f9cf (patch)
tree7605e90bef7b67ea957030cc7404161bd723b738 /src/or/Makefile.am
parent4cb21bab4811090ca7f39bd422eed5184c58e5bf (diff)
downloadtor-f34e6da3e75ad5b681c68e6c0a50d65d4566f9cf.tar.gz
tor-f34e6da3e75ad5b681c68e6c0a50d65d4566f9cf.zip
now circuit_get_newest returns an appropriate circ for your purpose
connection_ap_handshake_attach_circuit attaches to a circ of the right purpose add a skeletal rendclient.c svn:r1441
Diffstat (limited to 'src/or/Makefile.am')
-rw-r--r--src/or/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/or/Makefile.am b/src/or/Makefile.am
index c96089eb82..afee6a713c 100644
--- a/src/or/Makefile.am
+++ b/src/or/Makefile.am
@@ -7,8 +7,8 @@ bin_PROGRAMS = tor
tor_SOURCES = buffers.c circuit.c command.c config.c \
connection.c connection_edge.c connection_or.c \
cpuworker.c directory.c dirserv.c dns.c main.c \
- onion.c rendcommon.c rendmid.c rendservice.c rephist.c \
- router.c routerlist.c \
+ onion.c rendcommon.c rendclient.c rendmid.c \
+ rendservice.c rephist.c router.c routerlist.c \
tor_main.c
tor_LDADD = ../common/libor.a
@@ -16,8 +16,8 @@ tor_LDADD = ../common/libor.a
test_SOURCES = buffers.c circuit.c command.c config.c \
connection.c connection_edge.c connection_or.c \
cpuworker.c directory.c dirserv.c dns.c main.c \
- onion.c rendcommon.c rendmid.c rendservice.c rephist.c \
- router.c routerlist.c \
+ onion.c rendcommon.c rendclient.c rendmid.c \
+ rendservice.c rephist.c router.c routerlist.c \
test.c
test_LDADD = ../common/libor.a