aboutsummaryrefslogtreecommitdiff
path: root/src/or/Makefile.am
diff options
context:
space:
mode:
authorSebastian Hahn <sebastian@torproject.org>2011-05-06 15:34:00 +0200
committerSebastian Hahn <sebastian@torproject.org>2011-05-06 15:38:32 +0200
commite36f9d1d9beec0daed57b68f936293dccc77b171 (patch)
tree42fbeb70c242f04665e2f35f49ccb773ea667219 /src/or/Makefile.am
parenta740994c771b5a4ecfba6a9f6f6fc57758a4b9f8 (diff)
downloadtor-e36f9d1d9beec0daed57b68f936293dccc77b171.tar.gz
tor-e36f9d1d9beec0daed57b68f936293dccc77b171.zip
Link to libevent_openssl statically when requested
When configure tor with --enable-bufferevents and --enable-static-libevent, libevent_openssl would still be linked dynamically. Fix this and refactor src/or/Makefile.am along the way.
Diffstat (limited to 'src/or/Makefile.am')
-rw-r--r--src/or/Makefile.am7
1 files changed, 1 insertions, 6 deletions
diff --git a/src/or/Makefile.am b/src/or/Makefile.am
index f0d5a0f5f9..a12d56b73d 100644
--- a/src/or/Makefile.am
+++ b/src/or/Makefile.am
@@ -69,17 +69,12 @@ AM_CPPFLAGS = -DSHARE_DATADIR="\"$(datadir)\"" \
# This seems to matter nowhere but on windows, but I assure you that it
# matters a lot there, and is quite hard to debug if you forget to do it.
-if USE_BUFFEREVENTS
-levent_openssl_lib = -levent_openssl
-else
-levent_openssl_lib =
-endif
tor_LDFLAGS = @TOR_LDFLAGS_zlib@ @TOR_LDFLAGS_openssl@ @TOR_LDFLAGS_libevent@
tor_LDADD = ./libtor.a ../common/libor.a ../common/libor-crypto.a \
../common/libor-event.a \
@TOR_ZLIB_LIBS@ -lm @TOR_LIBEVENT_LIBS@ @TOR_OPENSSL_LIBS@ \
- @TOR_LIB_WS32@ @TOR_LIB_GDI@ $(levent_openssl_lib)
+ @TOR_LIB_WS32@ @TOR_LIB_GDI@
noinst_HEADERS = \
buffers.h \