aboutsummaryrefslogtreecommitdiff
path: root/src/or/Makefile.am
diff options
context:
space:
mode:
authorSebastian Hahn <sebastian@torproject.org>2010-04-14 16:48:05 +0200
committerSebastian Hahn <sebastian@torproject.org>2010-04-14 19:28:21 +0200
commit71fb687ddd2d9c11dbacbc9e115b1c95620ae5bd (patch)
tree91c03a0ed432f8cf409f893ae0a810d416161242 /src/or/Makefile.am
parentfe57aab2832160d1c256aa9d6e70cd5e1cd29aa4 (diff)
downloadtor-71fb687ddd2d9c11dbacbc9e115b1c95620ae5bd.tar.gz
tor-71fb687ddd2d9c11dbacbc9e115b1c95620ae5bd.zip
Add --enable-static-zlib option
Works like the --enable-static-openssl/libevent options. Requires --with-zlib-dir to be set. Note that other dependencies might still pull in a dynamicly linked zlib, if you don't link them in statically too.
Diffstat (limited to 'src/or/Makefile.am')
-rw-r--r--src/or/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/or/Makefile.am b/src/or/Makefile.am
index cfa8a035ad..a354db5db3 100644
--- a/src/or/Makefile.am
+++ b/src/or/Makefile.am
@@ -43,7 +43,7 @@ AM_CPPFLAGS = -DSHARE_DATADIR="\"$(datadir)\"" \
tor_LDFLAGS = @TOR_LDFLAGS_zlib@ @TOR_LDFLAGS_openssl@ @TOR_LDFLAGS_libevent@
tor_LDADD = ./libtor.a ../common/libor.a ../common/libor-crypto.a \
../common/libor-event.a \
- -lz -lm @TOR_LIBEVENT_LIBS@ @TOR_OPENSSL_LIBS@ @TOR_LIB_WS32@ @TOR_LIB_GDI@
+ @TOR_ZLIB_LIBS@ -lm @TOR_LIBEVENT_LIBS@ @TOR_OPENSSL_LIBS@ @TOR_LIB_WS32@ @TOR_LIB_GDI@
noinst_HEADERS = or.h eventdns.h eventdns_tor.h micro-revision.i