aboutsummaryrefslogtreecommitdiff
path: root/src/or/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2009-05-08 12:35:36 -0400
committerNick Mathewson <nickm@torproject.org>2009-05-08 12:35:36 -0400
commitfdbdb4dc15004fdb74c57b9bc67cbfca24c6e7ea (patch)
treeff07070534ccab65e0cda66bb29f009b1d110685 /src/or/Makefile.am
parentb9b16ef9a5c7c84f41f95e0e2c8266f4c1e2dce2 (diff)
downloadtor-fdbdb4dc15004fdb74c57b9bc67cbfca24c6e7ea.tar.gz
tor-fdbdb4dc15004fdb74c57b9bc67cbfca24c6e7ea.zip
Include the *_sha1.i files in their own *_codedigest.c files.
This way we do not need to rebuild util.c and/or config.c whenever any unrelated source file in src/common or src/or has changed.
Diffstat (limited to 'src/or/Makefile.am')
-rw-r--r--src/or/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/or/Makefile.am b/src/or/Makefile.am
index 03e7900944..11923fbd35 100644
--- a/src/or/Makefile.am
+++ b/src/or/Makefile.am
@@ -20,7 +20,7 @@ tor_SOURCES = buffers.c circuitbuild.c circuitlist.c \
networkstatus.c onion.c policies.c \
reasons.c relay.c rendcommon.c rendclient.c rendmid.c \
rendservice.c rephist.c router.c routerlist.c routerparse.c \
- eventdns.c \
+ eventdns.c config_codedigest.c \
tor_main.c
AM_CPPFLAGS = -DSHARE_DATADIR="\"$(datadir)\"" \
@@ -42,7 +42,7 @@ test_SOURCES = buffers.c circuitbuild.c circuitlist.c \
networkstatus.c onion.c policies.c \
reasons.c relay.c rendcommon.c rendclient.c rendmid.c \
rendservice.c rephist.c router.c routerlist.c routerparse.c \
- eventdns.c \
+ eventdns.c config_codedigest.c \
test_data.c test.c
test_LDFLAGS = @TOR_LDFLAGS_zlib@ @TOR_LDFLAGS_openssl@ \
@@ -52,7 +52,7 @@ test_LDADD = ../common/libor.a ../common/libor-crypto.a \
noinst_HEADERS = or.h eventdns.h eventdns_tor.h micro-revision.i
-config.o: or_sha1.i
+config_codedigest.o: or_sha1.i
tor_main.o: micro-revision.i