aboutsummaryrefslogtreecommitdiff
path: root/src/or/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2010-01-24 14:34:47 -0500
committerNick Mathewson <nickm@torproject.org>2010-01-24 14:34:47 -0500
commitb6038f4ac646b52f0819724b344adcf04bc2a440 (patch)
tree677f03b639a8ea591f0ee56cacceb2c1354409a4 /src/or/Makefile.am
parentca60a6ce3f4786626ac455ec1b798b2e8304635c (diff)
downloadtor-b6038f4ac646b52f0819724b344adcf04bc2a440.tar.gz
tor-b6038f4ac646b52f0819724b344adcf04bc2a440.zip
Add --enable-static-(openssl|libevent) options
These options only work when using --with-(openssl|libevent)-dir to explicitly pick a libevent or openssl location.
Diffstat (limited to 'src/or/Makefile.am')
-rw-r--r--src/or/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/or/Makefile.am b/src/or/Makefile.am
index 28d7e736dc..ad2476ff15 100644
--- a/src/or/Makefile.am
+++ b/src/or/Makefile.am
@@ -33,7 +33,7 @@ AM_CPPFLAGS = -DSHARE_DATADIR="\"$(datadir)\"" \
tor_LDFLAGS = @TOR_LDFLAGS_zlib@ @TOR_LDFLAGS_openssl@ @TOR_LDFLAGS_libevent@
tor_LDADD = ../common/libor.a ../common/libor-crypto.a \
- -lz -levent -lssl -lcrypto @TOR_LIB_WS32@ @TOR_LIB_GDI@
+ -lz @TOR_LIBEVENT_LIBS@ @TOR_OPENSSL_LIBS@ @TOR_LIB_WS32@ @TOR_LIB_GDI@
test_SOURCES = buffers.c circuitbuild.c circuitlist.c \
circuituse.c command.c config.c \
connection.c connection_edge.c connection_or.c control.c \
@@ -48,7 +48,7 @@ test_SOURCES = buffers.c circuitbuild.c circuitlist.c \
test_LDFLAGS = @TOR_LDFLAGS_zlib@ @TOR_LDFLAGS_openssl@ \
@TOR_LDFLAGS_libevent@
test_LDADD = ../common/libor.a ../common/libor-crypto.a \
- -lz -levent -lssl -lcrypto @TOR_LIB_WS32@ @TOR_LIB_GDI@
+ -lz @TOR_LIBEVENT_LIBS@ @TOR_OPENSSL_LIBS@ @TOR_LIB_WS32@ @TOR_LIB_GDI@
noinst_HEADERS = or.h eventdns.h eventdns_tor.h micro-revision.i