aboutsummaryrefslogtreecommitdiff
path: root/src/or/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2004-03-31 21:35:23 +0000
committerNick Mathewson <nickm@torproject.org>2004-03-31 21:35:23 +0000
commitbf83b1e345bcdcdd95950ce5decf6c19cbc93568 (patch)
treef253c616c1b1d0048a84c8ed95ba8623bec423aa /src/or/Makefile.am
parent157cd7fe1528be75b3064642ec1f3a3db8f77ca7 (diff)
downloadtor-bf83b1e345bcdcdd95950ce5decf6c19cbc93568.tar.gz
tor-bf83b1e345bcdcdd95950ce5decf6c19cbc93568.zip
Add code to configure hidden services, parse configuration, generate keys and service IDs, and store/load them from disk
svn:r1410
Diffstat (limited to 'src/or/Makefile.am')
-rw-r--r--src/or/Makefile.am20
1 files changed, 12 insertions, 8 deletions
diff --git a/src/or/Makefile.am b/src/or/Makefile.am
index 7568df7f37..fbdac98201 100644
--- a/src/or/Makefile.am
+++ b/src/or/Makefile.am
@@ -4,17 +4,21 @@ noinst_PROGRAMS = test
bin_PROGRAMS = tor
-tor_SOURCES = buffers.c circuit.c command.c connection.c \
- connection_or.c config.c dirserv.c rendcommon.c \
- onion.c router.c routerlist.c directory.c dns.c connection_edge.c \
- rephist.c cpuworker.c main.c tor_main.c
+tor_SOURCES = buffers.c circuit.c command.c config.c \
+ connection.c connection_edge.c connection_or.c \
+ cpuworker.c directory.c dirserv.c dns.c main.c \
+ onion.c rendcommon.c rendservice.c rephist.c \
+ router.c routerlist.c \
+ tor_main.c
tor_LDADD = ../common/libor.a
-test_SOURCES = buffers.c circuit.c command.c connection.c \
- connection_or.c config.c dirserv.c rendcommon.c \
- onion.c router.c routerlist.c directory.c dns.c connection_edge.c \
- rephist.c cpuworker.c main.c test.c
+test_SOURCES = buffers.c circuit.c command.c config.c \
+ connection.c connection_edge.c connection_or.c \
+ cpuworker.c directory.c dirserv.c dns.c main.c \
+ onion.c rendcommon.c rendservice.c rephist.c \
+ router.c routerlist.c \
+ test.c
test_LDADD = ../common/libor.a