aboutsummaryrefslogtreecommitdiff
path: root/src/or/Makefile.am
diff options
context:
space:
mode:
authorRoger Dingledine <arma@torproject.org>2004-05-13 07:24:49 +0000
committerRoger Dingledine <arma@torproject.org>2004-05-13 07:24:49 +0000
commitef561c0e42dcd33a2ca8ee29a582dd68da32f3be (patch)
treedeb933ba547882bf8a0300674745c8f4c4922757 /src/or/Makefile.am
parent6c68187e9f7e86a6a5d0e49a2bc99b0994df7ae0 (diff)
downloadtor-ef561c0e42dcd33a2ca8ee29a582dd68da32f3be.tar.gz
tor-ef561c0e42dcd33a2ca8ee29a582dd68da32f3be.zip
Break files apart into more modules
* \file circuitbuild.c * \brief The actual details of building circuits. * \file circuitlist.c * \brief Manage the global circuit list. * \file circuituse.c * \brief Launch the right sort of circuits, attach streams to them. * \file connection_edge.c * \brief Handle edge streams. * \file onion.c * \brief Functions to queue create cells, and handle onionskin * parsing and creation. * \file relay.c * \brief Handle relay cell encryption/decryption, plus packaging and * receiving from circuits. svn:r1863
Diffstat (limited to 'src/or/Makefile.am')
-rw-r--r--src/or/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/or/Makefile.am b/src/or/Makefile.am
index 961cd95143..a071bceba6 100644
--- a/src/or/Makefile.am
+++ b/src/or/Makefile.am
@@ -4,7 +4,8 @@ noinst_PROGRAMS = test
bin_PROGRAMS = tor
-tor_SOURCES = buffers.c circuit.c command.c config.c \
+tor_SOURCES = buffers.c circuitbuild.c circuitlist.c \
+ circuituse.c command.c config.c \
connection.c connection_edge.c connection_or.c \
cpuworker.c directory.c dirserv.c dns.c main.c \
onion.c relay.c rendcommon.c rendclient.c rendmid.c \
@@ -13,7 +14,8 @@ tor_SOURCES = buffers.c circuit.c command.c config.c \
tor_LDADD = ../common/libor.a
-test_SOURCES = buffers.c circuit.c command.c config.c \
+test_SOURCES = buffers.c circuitbuild.c circuitlist.c \
+ circuituse.c command.c config.c \
connection.c connection_edge.c connection_or.c \
cpuworker.c directory.c dirserv.c dns.c main.c \
onion.c relay.c rendcommon.c rendclient.c rendmid.c \