summaryrefslogtreecommitdiff
path: root/src/or/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2003-04-07 02:12:02 +0000
committerNick Mathewson <nickm@torproject.org>2003-04-07 02:12:02 +0000
commitc217b1ca711538d5c6e49a56c1047e021eb0fb3c (patch)
tree39286439eb4e9e8481fb440d1de8a7c81291c1f9 /src/or/Makefile.am
parentafa95ca47c06232f7395af0f7197eab61e1d91c3 (diff)
downloadtor-c217b1ca711538d5c6e49a56c1047e021eb0fb3c.tar.gz
tor-c217b1ca711538d5c6e49a56c1047e021eb0fb3c.zip
Add magic to end of C files to make emacs happy; split test invocation into separate file.
svn:r224
Diffstat (limited to 'src/or/Makefile.am')
-rw-r--r--src/or/Makefile.am19
1 files changed, 11 insertions, 8 deletions
diff --git a/src/or/Makefile.am b/src/or/Makefile.am
index bb84b03522..9b7c5a38a8 100644
--- a/src/or/Makefile.am
+++ b/src/or/Makefile.am
@@ -1,19 +1,22 @@
+TESTS = test
-TESTS = test_config
-
-noinst_PROGRAMS = test_config
+noinst_PROGRAMS = test
bin_PROGRAMS = or
-or_LDADD = -L../common -lor -lz
-
or_SOURCES = buffers.c circuit.c command.c connection.c \
connection_exit.c connection_ap.c connection_op.c connection_or.c config.c \
- main.c onion.c routers.c directory.c dns.c
+ onion.c routers.c directory.c dns.c \
+ main.c tor_main.c
-test_config_SOURCES = test_config.c config.c
+or_LDADD = -L../common -lor -lz
+
+test_SOURCES = buffers.c circuit.c command.c connection.c \
+ connection_exit.c connection_ap.c connection_op.c connection_or.c config.c \
+ onion.c routers.c directory.c dns.c \
+ main.c test.c
-test_config_LDADD = -L../common -lor
+test_LDADD = -L../common -lor -lz
noinst_HEADERS = or.h tree.h