summaryrefslogtreecommitdiff
path: root/src/common/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2009-05-08 12:35:36 -0400
committerNick Mathewson <nickm@torproject.org>2009-05-08 12:35:36 -0400
commitfdbdb4dc15004fdb74c57b9bc67cbfca24c6e7ea (patch)
treeff07070534ccab65e0cda66bb29f009b1d110685 /src/common/Makefile.am
parentb9b16ef9a5c7c84f41f95e0e2c8266f4c1e2dce2 (diff)
downloadtor-fdbdb4dc15004fdb74c57b9bc67cbfca24c6e7ea.tar.gz
tor-fdbdb4dc15004fdb74c57b9bc67cbfca24c6e7ea.zip
Include the *_sha1.i files in their own *_codedigest.c files.
This way we do not need to rebuild util.c and/or config.c whenever any unrelated source file in src/common or src/or has changed.
Diffstat (limited to 'src/common/Makefile.am')
-rw-r--r--src/common/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/common/Makefile.am b/src/common/Makefile.am
index 78c8ab5516..ad54e1aaaa 100644
--- a/src/common/Makefile.am
+++ b/src/common/Makefile.am
@@ -12,7 +12,7 @@ libor_extra_source=
endif
libor_a_SOURCES = address.c log.c util.c compat.c container.c mempool.c \
- memarea.c $(libor_extra_source)
+ memarea.c util_codedigest.c $(libor_extra_source)
libor_crypto_a_SOURCES = crypto.c aes.c tortls.c torgzip.c
noinst_HEADERS = address.h log.h crypto.h test.h util.h compat.h aes.h torint.h tortls.h strlcpy.c strlcat.c torgzip.h container.h ht.h mempool.h memarea.h ciphers.inc
@@ -27,4 +27,4 @@ common_sha1.i: $(libor_SOURCES) $(libor_crypto_a_SOURCES) $(noinst_HEADERS)
touch common_sha1.i; \
fi
-util.o: common_sha1.i
+util_codedigest.o: common_sha1.i