summaryrefslogtreecommitdiff
path: root/src/common/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2008-02-17 19:03:49 +0000
committerNick Mathewson <nickm@torproject.org>2008-02-17 19:03:49 +0000
commita8b371c333a03976111874a343c748c0fdbc8140 (patch)
tree6f796c3bcf11ee4c4585bf24f45c4dfd1ad64f14 /src/common/Makefile.am
parentfaa56a500b4bcdac6306c0c8b923bb1fb22267ec (diff)
downloadtor-a8b371c333a03976111874a343c748c0fdbc8140.tar.gz
tor-a8b371c333a03976111874a343c748c0fdbc8140.zip
r14238@tombo: nickm | 2008-02-17 14:03:44 -0500
Add openbsd memory allocator discussed in bug 468, to make it easier for linux users to get non-awful allocation patterns. Use --enable-openbsd-malloc to turn it on. Needs more testing. svn:r13544
Diffstat (limited to 'src/common/Makefile.am')
-rw-r--r--src/common/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/common/Makefile.am b/src/common/Makefile.am
index d48678f505..47964e0aa5 100644
--- a/src/common/Makefile.am
+++ b/src/common/Makefile.am
@@ -6,4 +6,8 @@ noinst_LIBRARIES = libor.a libor-crypto.a
libor_a_SOURCES = log.c util.c compat.c container.c mempool.c
libor_crypto_a_SOURCES = crypto.c aes.c tortls.c torgzip.c
+if USE_OPENBSD_MALLOC
+libor_a_SOURCES += OpenBSD_Malloc_Linux.c
+endif
+
noinst_HEADERS = log.h crypto.h test.h util.h compat.h aes.h torint.h tortls.h strlcpy.c strlcat.c torgzip.h container.h ht.h mempool.h