summaryrefslogtreecommitdiff
path: root/src/common/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2008-06-12 22:39:13 +0000
committerNick Mathewson <nickm@torproject.org>2008-06-12 22:39:13 +0000
commit617843988cc7dc6ed51c4ac409abe26f5ead5ccf (patch)
tree12bc840334fec69dcaf2de89df8d1f48787b7e8e /src/common/Makefile.am
parent555450ba735e5ea108226e332bf530acfefffdca (diff)
downloadtor-617843988cc7dc6ed51c4ac409abe26f5ead5ccf.tar.gz
tor-617843988cc7dc6ed51c4ac409abe26f5ead5ccf.zip
r16215@tombo: nickm | 2008-06-12 18:39:03 -0400
Implement code to manually force the OpenSSL client cipher list to match the one recommended in proposal 124, *even if* we do not know all those ciphers. This is a bit of a kludge, but it is at least decently well commented. svn:r15173
Diffstat (limited to 'src/common/Makefile.am')
-rw-r--r--src/common/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/common/Makefile.am b/src/common/Makefile.am
index 56f3fabb6a..174d8ea99c 100644
--- a/src/common/Makefile.am
+++ b/src/common/Makefile.am
@@ -13,4 +13,4 @@ libor_a_SOURCES = log.c util.c compat.c container.c mempool.c memarea.c \
$(libor_extra_source)
libor_crypto_a_SOURCES = crypto.c aes.c tortls.c torgzip.c
-noinst_HEADERS = log.h crypto.h test.h util.h compat.h aes.h torint.h tortls.h strlcpy.c strlcat.c torgzip.h container.h ht.h mempool.h memarea.h
+noinst_HEADERS = log.h crypto.h test.h util.h compat.h aes.h torint.h tortls.h strlcpy.c strlcat.c torgzip.h container.h ht.h mempool.h memarea.h ciphers.inc