summaryrefslogtreecommitdiff
path: root/src/common/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2009-08-20 01:47:13 -0400
committerNick Mathewson <nickm@torproject.org>2009-08-20 01:47:13 -0400
commitd0c212995a29644e0357c81abbc0e7ea652d2504 (patch)
tree56a54987b3b550e316a6035b24c34320723c309b /src/common/Makefile.am
parentf57883a39e09e16f495a6b8706ca0d3b3a8df2a4 (diff)
downloadtor-d0c212995a29644e0357c81abbc0e7ea652d2504.tar.gz
tor-d0c212995a29644e0357c81abbc0e7ea652d2504.zip
Add a SHA256 implementation for platforms that lack it.
(This would be everywhere running OpenSSL 0.9.7x and earlier, including all current Macintosh users.) The code is based on Tom St Denis's LibTomCrypt implementation, modified to be way less general and use Tor's existing facilities. I picked this one because it was pretty fast and pretty free, and because Python uses it too.
Diffstat (limited to 'src/common/Makefile.am')
-rw-r--r--src/common/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/common/Makefile.am b/src/common/Makefile.am
index 78f73db25f..96013845e6 100644
--- a/src/common/Makefile.am
+++ b/src/common/Makefile.am
@@ -1,7 +1,7 @@
noinst_LIBRARIES = libor.a libor-crypto.a libor-event.a
-EXTRA_DIST = common_sha1.i
+EXTRA_DIST = common_sha1.i sha256.c
#CFLAGS = -Wall -Wpointer-arith -O2
@@ -29,3 +29,4 @@ common_sha1.i: $(libor_SOURCES) $(libor_crypto_a_SOURCES) $(noinst_HEADERS)
fi
util_codedigest.o: common_sha1.i
+crypto.o: sha256.c