summaryrefslogtreecommitdiff
path: root/src/common/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2009-09-24 13:00:28 -0400
committerNick Mathewson <nickm@torproject.org>2009-09-24 13:00:28 -0400
commita3f1da2ec067ada4231d0f1c0b6d597ff547d1d9 (patch)
tree17350c97a424198b373facdbaed96a4538560d2f /src/common/Makefile.am
parentb8b293536752725ebba5f14852095b512a009e75 (diff)
downloadtor-a3f1da2ec067ada4231d0f1c0b6d597ff547d1d9.tar.gz
tor-a3f1da2ec067ada4231d0f1c0b6d597ff547d1d9.zip
Fix compilation on OpenSSLs with unusual state lists.
"Unusual" in this context means "not the same as nickm's." We should grow a better list later. (Also, move TLS state table to a separate header.)
Diffstat (limited to 'src/common/Makefile.am')
-rw-r--r--src/common/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/common/Makefile.am b/src/common/Makefile.am
index d57593d633..eecfeb83fe 100644
--- a/src/common/Makefile.am
+++ b/src/common/Makefile.am
@@ -16,7 +16,7 @@ libor_a_SOURCES = address.c log.c util.c compat.c container.c mempool.c \
libor_crypto_a_SOURCES = crypto.c aes.c tortls.c torgzip.c
libor_event_a_SOURCES = compat_libevent.c
-noinst_HEADERS = address.h log.h crypto.h util.h compat.h aes.h torint.h tortls.h strlcpy.c strlcat.c torgzip.h container.h ht.h mempool.h memarea.h ciphers.inc compat_libevent.h
+noinst_HEADERS = address.h log.h crypto.h util.h compat.h aes.h torint.h tortls.h strlcpy.c strlcat.c torgzip.h container.h ht.h mempool.h memarea.h ciphers.inc compat_libevent.h tortls_states.h
common_sha1.i: $(libor_SOURCES) $(libor_crypto_a_SOURCES) $(noinst_HEADERS)
if test "@SHA1SUM@" != none; then \