summaryrefslogtreecommitdiff
path: root/src/common/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2007-04-11 00:30:22 +0000
committerNick Mathewson <nickm@torproject.org>2007-04-11 00:30:22 +0000
commitd7359eb996218f4492a5583c34ab8ee7d9315e7d (patch)
treeee45fedecacdfd83bea07a57bbf89cd8fa2c1463 /src/common/Makefile.am
parentf95d232483a0e9fd78563bfdc061016baab6ef97 (diff)
downloadtor-d7359eb996218f4492a5583c34ab8ee7d9315e7d.tar.gz
tor-d7359eb996218f4492a5583c34ab8ee7d9315e7d.zip
r12335@catbus: nickm | 2007-04-10 16:53:48 -0400
Initial version of memory pool logic. Needs unit tests. Made to be easily separable from Tor. svn:r9937
Diffstat (limited to 'src/common/Makefile.am')
-rw-r--r--src/common/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/common/Makefile.am b/src/common/Makefile.am
index 40acc38e88..d48678f505 100644
--- a/src/common/Makefile.am
+++ b/src/common/Makefile.am
@@ -3,7 +3,7 @@ noinst_LIBRARIES = libor.a libor-crypto.a
#CFLAGS = -Wall -Wpointer-arith -O2
-libor_a_SOURCES = log.c util.c compat.c container.c
+libor_a_SOURCES = log.c util.c compat.c container.c mempool.c
libor_crypto_a_SOURCES = crypto.c aes.c tortls.c torgzip.c
-noinst_HEADERS = log.h crypto.h test.h util.h compat.h aes.h torint.h tortls.h strlcpy.c strlcat.c torgzip.h container.h ht.h
+noinst_HEADERS = log.h crypto.h test.h util.h compat.h aes.h torint.h tortls.h strlcpy.c strlcat.c torgzip.h container.h ht.h mempool.h