summaryrefslogtreecommitdiff
path: root/src/common/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2008-03-26 16:33:33 +0000
committerNick Mathewson <nickm@torproject.org>2008-03-26 16:33:33 +0000
commite4ebe3409e941cf16b2a80a939848deb9e810ca3 (patch)
tree2b7cf9d451101be36c2bb304737ce9d4bb053462 /src/common/Makefile.am
parent9dfd4132c30db5966e73850c0eac372f544cc672 (diff)
downloadtor-e4ebe3409e941cf16b2a80a939848deb9e810ca3.tar.gz
tor-e4ebe3409e941cf16b2a80a939848deb9e810ca3.zip
r19049@catbus: nickm | 2008-03-26 12:33:25 -0400
Add new stacklike, free-all-at-once memory allocation strategy. Use it when parsing directory information. This helps parsing speed, and may well help fragmentation some too. hidden-service-related stuff still uses the old tokenizing strategies. svn:r14194
Diffstat (limited to 'src/common/Makefile.am')
-rw-r--r--src/common/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/common/Makefile.am b/src/common/Makefile.am
index 28702bb10a..56f3fabb6a 100644
--- a/src/common/Makefile.am
+++ b/src/common/Makefile.am
@@ -9,8 +9,8 @@ else
libor_extra_source=
endif
-libor_a_SOURCES = log.c util.c compat.c container.c mempool.c \
+libor_a_SOURCES = log.c util.c compat.c container.c mempool.c memarea.c \
$(libor_extra_source)
libor_crypto_a_SOURCES = crypto.c aes.c tortls.c torgzip.c
-noinst_HEADERS = log.h crypto.h test.h util.h compat.h aes.h torint.h tortls.h strlcpy.c strlcat.c torgzip.h container.h ht.h mempool.h
+noinst_HEADERS = log.h crypto.h test.h util.h compat.h aes.h torint.h tortls.h strlcpy.c strlcat.c torgzip.h container.h ht.h mempool.h memarea.h