summaryrefslogtreecommitdiff
path: root/src/common/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2005-01-12 06:42:32 +0000
committerNick Mathewson <nickm@torproject.org>2005-01-12 06:42:32 +0000
commit324b192f68bfe697009831a5bad3acdd7bd2cec5 (patch)
tree13f8d3bd453244fcad1f519667bb4483156113bf /src/common/Makefile.am
parent9b578f2fe2665a1b1a75f6fb5a85f8a77ee31545 (diff)
downloadtor-324b192f68bfe697009831a5bad3acdd7bd2cec5.tar.gz
tor-324b192f68bfe697009831a5bad3acdd7bd2cec5.zip
Make Tor use Niels Provos's libevent instead of it's current
poll-but-sometimes-select mess. This will let us use faster async cores (like epoll, kpoll, and /dev/poll), and hopefully work better on Windows too. There are some fairly nasty changes to main.c here; this will almost certainly break something. But hey, that's what alphas are for. svn:r3341
Diffstat (limited to 'src/common/Makefile.am')
-rw-r--r--src/common/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/common/Makefile.am b/src/common/Makefile.am
index 65f722bfe8..ae3f8a8f7f 100644
--- a/src/common/Makefile.am
+++ b/src/common/Makefile.am
@@ -3,7 +3,7 @@ noinst_LIBRARIES = libor.a libor-crypto.a
#CFLAGS = -Wall -Wpointer-arith -O2
-libor_a_SOURCES = log.c fakepoll.c util.c compat.c container.c
+libor_a_SOURCES = log.c util.c compat.c container.c
libor_crypto_a_SOURCES = crypto.c aes.c tortls.c torgzip.c
-noinst_HEADERS = log.h crypto.h fakepoll.h test.h util.h compat.h aes.h torint.h tortls.h strlcpy.c strlcat.c torgzip.h container.h
+noinst_HEADERS = log.h crypto.h test.h util.h compat.h aes.h torint.h tortls.h strlcpy.c strlcat.c torgzip.h container.h