summaryrefslogtreecommitdiff
path: root/src/common/Makefile.am
diff options
context:
space:
mode:
authorFelipe Bergo <bergo@seul.org>2002-06-28 23:26:42 +0000
committerFelipe Bergo <bergo@seul.org>2002-06-28 23:26:42 +0000
commitf09e25e9f561eb0b95e559af182de0a4626384fa (patch)
tree6a3140d86b6bb521b33764ef863a1f220751c8f8 /src/common/Makefile.am
parent92019ca9e7f58e8cad5f80b5a43ce01989415edf (diff)
downloadtor-f09e25e9f561eb0b95e559af182de0a4626384fa.tar.gz
tor-f09e25e9f561eb0b95e559af182de0a4626384fa.zip
added automake/autoconf support. When in doubt, "aclocal && autoconf && autoheader && automake" from the top dir.
svn:r10
Diffstat (limited to 'src/common/Makefile.am')
-rw-r--r--src/common/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/common/Makefile.am b/src/common/Makefile.am
new file mode 100644
index 0000000000..f7fa778f10
--- /dev/null
+++ b/src/common/Makefile.am
@@ -0,0 +1,14 @@
+
+noinst_LIBRARIES = libor.a
+
+#CFLAGS = -Wall -Wpointer-arith -O2
+
+libor_a_SOURCES = cell.c config.c key.c log.c onion.c opcell.c \
+ routent.c scheduler.c utils.c
+
+# ss.h is not used anywhere, distributing it just because
+
+noinst_HEADERS = cell.h config.h key.h log.h onion.h opcell.h \
+ policies.h routent.h scheduler.h utils.h \
+ ss.h version.h
+