aboutsummaryrefslogtreecommitdiff
path: root/src/common/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2011-05-09 18:39:23 -0400
committerNick Mathewson <nickm@torproject.org>2011-05-11 16:12:33 -0400
commit4b19730c8234de3587bd50256fcb11660fb07388 (patch)
tree01a606ed8b66ea94ec482395b09c16762b9bc91a /src/common/Makefile.am
parent8a36f2125137dc31a0771a8eeac0f2bb8c1343d0 (diff)
downloadtor-4b19730c8234de3587bd50256fcb11660fb07388.tar.gz
tor-4b19730c8234de3587bd50256fcb11660fb07388.zip
Add a data-independent variant of memcmp and a d-i memeq function.
The tor_memcmp code is by Robert Ransom, and the tor_memeq code is by me. Both incorporate some ideas from DJB's stuff.
Diffstat (limited to 'src/common/Makefile.am')
-rw-r--r--src/common/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/common/Makefile.am b/src/common/Makefile.am
index 105c413343..db94a984ca 100644
--- a/src/common/Makefile.am
+++ b/src/common/Makefile.am
@@ -10,7 +10,7 @@ libor_extra_source=
endif
libor_a_SOURCES = address.c log.c util.c compat.c container.c mempool.c \
- memarea.c $(libor_extra_source)
+ memarea.c di_ops.c $(libor_extra_source)
libor_crypto_a_SOURCES = crypto.c aes.c tortls.c torgzip.c
-noinst_HEADERS = address.h log.h crypto.h test.h util.h compat.h aes.h torint.h tortls.h strlcpy.c strlcat.c torgzip.h container.h ht.h mempool.h memarea.h ciphers.inc
+noinst_HEADERS = address.h log.h crypto.h test.h util.h compat.h aes.h torint.h tortls.h strlcpy.c strlcat.c torgzip.h container.h ht.h mempool.h memarea.h di_ops.h ciphers.inc