summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorLinus Nordberg <linus@torproject.org>2010-08-09 21:44:21 +0200
committerNick Mathewson <nickm@torproject.org>2010-08-11 09:41:34 -0400
commit0b96abe74fab3aa200644b933c069afb1d26ae76 (patch)
treea84ea110ec18323daab4a4551cc9bb8c6a8a7219 /doc/Makefile.am
parent863b6c439e6bfc64f602ecb9526940fa966ca9fe (diff)
downloadtor-0b96abe74fab3aa200644b933c069afb1d26ae76.tar.gz
tor-0b96abe74fab3aa200644b933c069afb1d26ae76.zip
Bug #1773: Revert bad fix (4ef609b8) and do it properly.
* doc/Makefile.am: Move $(VAR:MOD) expansions inside "if USE_ASCIIDOC". * doc/Makefile.am: Use proper variable name for text input files. * doc/Makefile.am: Initialize vars to empty when !USE_ASCIIDOC.
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am20
1 files changed, 11 insertions, 9 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 2e70fd7474..0f649d664a 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -15,25 +15,27 @@
if USE_ASCIIDOC
asciidoc_files = tor tor-gencert tor-resolve torify
+html_in = $(asciidoc_files:=.html.in)
+man_in = $(asciidoc_files:=.1.in)
+txt_in = $(asciidoc_files:=.1.txt)
+nodist_man_MANS = $(asciidoc_files:=.1)
+doc_DATA = $(asciidoc_files:=.html)
else
asciidoc_files =
+html_in =
+man_in =
+txt_in =
+nodist_man_MANS =
+doc_DATA =
endif
-html_in = ${asciidoc_files:=.html.in}
-
-man_in = ${asciidoc_files:=.1.in}
-
EXTRA_DIST = HACKING asciidoc-helper.sh \
- $(html_in) $(man_in) ${asciidoc_files:=.1.txt} \
+ $(html_in) $(man_in) $(txt_in) \
tor-osx-dmg-creation.txt tor-rpm-creation.txt \
tor-win32-mingw-creation.txt
-nodist_man_MANS = ${asciidoc_files:=.1}
-
docdir = @docdir@
-doc_DATA = ${asciidoc_files:=.html}
-
asciidoc_product = $(nodist_man_MANS) $(doc_DATA)
SUBDIRS = spec