summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorSebastian Hahn <sebastian@torproject.org>2010-09-30 22:44:11 +0200
committerSebastian Hahn <sebastian@torproject.org>2010-09-30 23:13:24 +0200
commitd67bdddec508237bf7e5475893d67f028a9b007e (patch)
tree3a5f5e76aa29fc0267d8186a573a5e2b4ff025c1 /doc/Makefile.am
parentd2cca82b7688f96238bfd929633c998bfe86e31b (diff)
downloadtor-d67bdddec508237bf7e5475893d67f028a9b007e.tar.gz
tor-d67bdddec508237bf7e5475893d67f028a9b007e.zip
Build the tor-fw-helper manpage
So far we just had the asciidoc manpage, but didn't build it.
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 68747c8d2d..500a57c7b6 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -14,7 +14,11 @@
# just use the .1 and .html files.
if USE_ASCIIDOC
+if USE_FW_HELPER
+asciidoc_files = tor tor-gencert tor-resolve torify tor-fw-helper
+else
asciidoc_files = tor tor-gencert tor-resolve torify
+endif
html_in = $(asciidoc_files:=.html.in)
man_in = $(asciidoc_files:=.1.in)
txt_in = $(asciidoc_files:=.1.txt)
@@ -51,6 +55,7 @@ tor.html.in : tor.1.txt
torify.html.in : torify.1.txt
tor-gencert.html.in : tor-gencert.1.txt
tor-resolve.html.in : tor-resolve.1.txt
+tor-fw-helper.html.in : tor-fw-helper.1.txt
# Generate the manpage from asciidoc, but don't do
# machine-specific replacements yet
@@ -61,6 +66,7 @@ tor.1.in : tor.1.txt
torify.1.in : torify.1.txt
tor-gencert.1.in : tor-gencert.1.txt
tor-resolve.1.in : tor-resolve.1.txt
+tor-fw-helper.1.in : tor-fw-helper.1.txt
# use ../config.status to swap all machine-specific magic strings
# in the asciidoc with their replacements.
@@ -74,10 +80,12 @@ tor.1 : tor.1.in
torify.1 : torify.1.in
tor-gencert.1 : tor-gencert.1.in
tor-resolve.1 : tor-resolve.1.in
+tor-fw-helper.1 : tor-fw-helper.1.in
tor.html : tor.html.in
torify.html : torify.html.in
tor-gencert.html : tor-gencert.html.in
tor-resolve.html : tor-resolve.html.in
+tor-fw-helper.html : tor-fw-helper.html.in
CLEANFILES = $(asciidoc_product) config.log
DISTCLEANFILES = $(html_in) $(man_in)