summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorLinus Nordberg <linus@torproject.org>2010-07-30 13:54:38 +0200
committerNick Mathewson <nickm@torproject.org>2010-07-30 11:34:52 -0400
commit4ef609b88609fc498aef94249179c20df0976dbf (patch)
treee611ac5ab1877eae23c39c140ce580bb0b59aa91 /doc/Makefile.am
parent4727adf591c4f8df115a639f67882578314eea8b (diff)
downloadtor-4ef609b88609fc498aef94249179c20df0976dbf.tar.gz
tor-4ef609b88609fc498aef94249179c20df0976dbf.zip
Fix compilation issue in doc/Makefile.am on NetBSD
* doc/Makefile.am: Change $(VAR:MOD) to ${VAR:MOD} -- make(1) on NetBSD substitutes '$(:x)' to 'x' rather than the empty string. This bites us in doc/ when configured with `--disable-asciidoc'. Curly braces should work in all implementations of make(1) but this patch changes only the places where we use the VAR:MOD expansion.
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index e7edb0476b..d976f9d6fa 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -19,20 +19,20 @@ else
asciidoc_files =
endif
-html_in = $(asciidoc_files:=.html.in)
+html_in = ${asciidoc_files:=.html.in}
-man_in = $(asciidoc_files:=.1.in)
+man_in = ${asciidoc_files:=.1.in}
EXTRA_DIST = HACKING asciidoc-helper.sh \
- $(html_in) $(man_in) $(asciidoc_files:=.1.txt) \
+ $(html_in) $(man_in) ${asciidoc_files:=.1.txt} \
tor-osx-dmg-creation.txt tor-rpm-creation.txt \
tor-win32-mingw-creation.txt
-nodist_man_MANS = $(asciidoc_files:=.1)
+nodist_man_MANS = ${asciidoc_files:=.1}
docdir = @docdir@
-doc_DATA = $(asciidoc_files:=.html)
+doc_DATA = ${asciidoc_files:=.html}
asciidoc_product = $(nodist_man_MANS) $(doc_DATA)