summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorPeter Palfrader <peter@palfrader.org>2008-01-21 15:00:34 +0000
committerPeter Palfrader <peter@palfrader.org>2008-01-21 15:00:34 +0000
commit17d711e25803e996280080b48c7ce64fb832fa80 (patch)
tree13844cad3c7ce2fb8f340eff3d2c44c510b89e60 /debian
parentd98d1ea0d9d0d8cb879aa5954bf4fedf4ae8d2a4 (diff)
downloadtor-17d711e25803e996280080b48c7ce64fb832fa80.tar.gz
tor-17d711e25803e996280080b48c7ce64fb832fa80.zip
postinst: if we reboot between unpacking and configuring on some smart systems
this will mean that we just lost /var/run/tor - creating it in the maintainer script if it doesn't exist. svn:r13208
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/tor.postinst8
2 files changed, 12 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index d04fdcfe01..27792eaede 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -12,8 +12,11 @@ tor (0.2.0.17-alpha-1+svn) experimental; urgency=low
and then later re-installed again. Now we ensure proper ownership
and modes for all the directories and files below /var/{lib,run,log}/tor
(the dirs themselves included) every time we run postinst.
+ * postinst: if we reboot between unpacking and configuring on some smart
+ systems this will mean that we just lost /var/run/tor - creating it
+ in the maintainer script if it doesn't exist.
- -- Peter Palfrader <weasel@debian.org> Mon, 21 Jan 2008 15:56:12 +0100
+ -- Peter Palfrader <weasel@debian.org> Mon, 21 Jan 2008 15:59:54 +0100
tor (0.2.0.17-alpha-1) experimental; urgency=low
diff --git a/debian/tor.postinst b/debian/tor.postinst
index efc7e25143..70b14eec9a 100644
--- a/debian/tor.postinst
+++ b/debian/tor.postinst
@@ -31,6 +31,14 @@ else
fi
+for i in lib run log; do
+ if ! [ -d "/var/$i/tor" ]; then
+ echo "Something or somebody made /var/$i/tor disappear."
+ echo "Creating one for you again."
+ mkdir "/var/$i/tor"
+ fi
+done
+
find /var/lib/tor ! -user debian-tor -o ! -group debian-tor -print0 | xargs -0 --no-run-if-empty chown debian-tor:debian-tor
find /var/lib/tor -type d -print0 | xargs -0 --no-run-if-empty chmod 02700
find /var/lib/tor -type f -print0 | xargs -0 --no-run-if-empty chmod 00600