summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorPeter Palfrader <peter@palfrader.org>2008-07-17 23:57:57 +0000
committerPeter Palfrader <peter@palfrader.org>2008-07-17 23:57:57 +0000
commit240bb9487e1bacfa99564e5c187661dd028c19c7 (patch)
treed8ad604ba9536f37a81dbeeb907d35faaddb9ea9 /debian
parentfed52f329a61aff675154ee47e7a81b1e536bb1c (diff)
downloadtor-240bb9487e1bacfa99564e5c187661dd028c19c7.tar.gz
tor-240bb9487e1bacfa99564e5c187661dd028c19c7.zip
Tweak a few error messages in the init script to use the proper variables (not
that it should matter, the Right One has the same value, but still) and to list more possible error reasons. svn:r16038
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog8
-rw-r--r--debian/tor.init8
2 files changed, 12 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 65caf235bb..f29a3376a0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+tor (0.2.0.30-X) unstable; urgency=low
+
+ * Tweak a few error messages in the init script to use the proper variables
+ (not that it should matter, the Right One has the same value, but still)
+ and to list more possible error reasons.
+
+ -- Peter Palfrader <weasel@debian.org> Fri, 18 Jul 2008 01:56:04 +0200
+
tor (0.2.0.30-2) unstable; urgency=low
* Stop requiring that the binary in /usr/sbin/tor is still the same as the
diff --git a/debian/tor.init b/debian/tor.init
index 99c550a881..af4b7bfef0 100644
--- a/debian/tor.init
+++ b/debian/tor.init
@@ -151,9 +151,9 @@ case "$1" in
echo "$NAME."
elif kill -0 $pid 2>/dev/null
then
- echo "FAILED (Is $pid not $NAME?)."
+ echo "FAILED (Is $pid not $DAEMON_NAME or not running as $DAEMON_USER?)."
else
- echo "FAILED ($DAEMON died: process $pid not running; or permission denied)."
+ echo "FAILED ($DAEMON_NAME died: process $pid not running; or permission denied)."
fi
;;
reload|force-reload)
@@ -172,9 +172,9 @@ case "$1" in
echo "$NAME."
elif kill -0 $pid 2>/dev/null
then
- echo "FAILED (Is $pid not $NAME?)."
+ echo "FAILED (Is $pid not $DAEMON_NAME or not running as $DAEMON_USER?)."
else
- echo "FAILED ($DAEMON died: process $pid not running; or permission denied)."
+ echo "FAILED ($DAEMON_NAME died: process $pid not running; or permission denied)."
fi
;;
restart)