summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorPeter Palfrader <peter@palfrader.org>2008-02-20 22:34:44 +0000
committerPeter Palfrader <peter@palfrader.org>2008-02-20 22:34:44 +0000
commitc92c5733d6384f20bcf96049a56d7b86f8f7e7a9 (patch)
tree96cbdcdf387721db0e535584e1cf83739db96bd7 /debian
parent93aa3355161923d722d196ebb27f35c8138c4c69 (diff)
downloadtor-c92c5733d6384f20bcf96049a56d7b86f8f7e7a9.tar.gz
tor-c92c5733d6384f20bcf96049a56d7b86f8f7e7a9.zip
if you have more than 40k FDs on your system let Tor use up to 16k of them by default
svn:r13627
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog15
-rw-r--r--debian/tor.init4
2 files changed, 12 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index 397e87392f..657e5c9147 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,13 +2,16 @@ tor (0.2.0.19-alpha+svn-1) unreleased; urgency=low
* Change the default for MAX_FILEDESCRIPTORS in our init script to depend
on the number of system-wide available file descriptors:
- /proc/sys/fs/file-max is bigger than 100k, set ulimit -n to 32k, if it's
- smaller than 20k set it to 1024. Big servers at the moment regularly use
- more than 10k FDs, so our old default of 8k no longer is sufficient. On
- the other hand we don't want lower end systems to run out of FDs on Tor's
- account.
+ /proc/sys/fs/file-max is bigger than 80k, set ulimit -n to 32k, if it's
+ greater than 40k set the limit to 16k, and when greater than 20k our limit
+ shall be 8k descriptors. If there are less than 20k FDs in the entire
+ system default to a limit of only 1024.
- -- Peter Palfrader <weasel@debian.org> Wed, 20 Feb 2008 23:27:35 +0100
+ Big servers at the moment regularly use more than 10k FDs, so our old
+ default of 8k no longer is sufficient. On the other hand we don't want
+ lower end systems to run out of FDs on Tor's account.
+
+ -- Peter Palfrader <weasel@debian.org> Wed, 20 Feb 2008 23:33:00 +0100
tor (0.2.0.19-alpha-1) experimental; urgency=low
diff --git a/debian/tor.init b/debian/tor.init
index 415467e87e..afb7f7eecc 100644
--- a/debian/tor.init
+++ b/debian/tor.init
@@ -28,8 +28,10 @@ ARGS=""
# Let's try to figure our some sane defaults:
if [ -r /proc/sys/fs/file-max ]; then
system_max=`cat /proc/sys/fs/file-max`
- if [ "$system_max" -gt "100000" ] ; then
+ if [ "$system_max" -gt "80000" ] ; then
MAX_FILEDESCRIPTORS=32768
+ elif [ "$system_max" -gt "40000" ] ; then
+ MAX_FILEDESCRIPTORS=16384
elif [ "$system_max" -gt "20000" ] ; then
MAX_FILEDESCRIPTORS=8192
else