summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorPeter Palfrader <peter@palfrader.org>2006-08-09 10:25:01 +0000
committerPeter Palfrader <peter@palfrader.org>2006-08-09 10:25:01 +0000
commit68fcef633c067a7f04e22ddfe6f0c26927496114 (patch)
tree2e1bb9c567faf34bfc17696455150d84dbb3f1c4 /debian
parent4b507f2cd0cd28a33fd06b2dd40f596ea9f3a545 (diff)
downloadtor-68fcef633c067a7f04e22ddfe6f0c26927496114.tar.gz
tor-68fcef633c067a7f04e22ddfe6f0c26927496114.zip
r8245@danube: weasel | 2006-08-09 12:24:00 +0200
Add a few comments so I find the rationale for the autoconf --build/--host split in the future when I need it again svn:r7000
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules7
1 files changed, 6 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index c593860b51..e52aae5a35 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,15 +11,20 @@ include /usr/share/dpatch/dpatch.make
# These are used for cross-compiling and for saving the configure script
# from having to guess our platform (since we know it already)
+#
+# See /usr/share/doc/autotools-dev/README.Debian.gz which suggests
+# this way of passing --build and --host. Also see the thread on
+# debian-devel './configure in debian/rules' from February/March 2006,
+# starting with <43FF212C.5020800@xs4all.nl> by Pjotr Kourzanov.
export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-CFLAGS ?= -Wall -g
ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
confflags += --build $(DEB_HOST_GNU_TYPE)
else
confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
endif
+CFLAGS ?= -Wall -g
LOCALHOST_IP ?= $(shell getent hosts localhost | awk '{print $$1}')