aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorPeter Palfrader <peter@palfrader.org>2008-02-03 17:18:35 +0000
committerPeter Palfrader <peter@palfrader.org>2008-02-03 17:18:35 +0000
commita06b6c7a616a96ab24185a7a592d14add7e286be (patch)
treea1d5a05d72b13ebb5fb11a248f0e7c683ccaa0f0 /debian
parent583bb548b069c43be09eda7feec320d9cbd0b447 (diff)
downloadtor-a06b6c7a616a96ab24185a7a592d14add7e286be.tar.gz
tor-a06b6c7a616a96ab24185a7a592d14add7e286be.zip
Fix postinst find command that chowns stuff to the right user. Find does weird things in the presence of !.
svn:r13364
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog8
-rw-r--r--debian/tor.postinst6
2 files changed, 7 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index 769b77bd58..bfd9c5f14f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,11 +1,11 @@
-tor (0.2.0.18-alpha+svn-1) experimental; urgency=low
+tor (0.2.0.18-alpha-2) experimental; urgency=low
- * 13351 + log
- *
* Work around fig2dev failing to build the images on mipsel like we do on
sparc and s390 (re #457568)
+ * Fix postinst find command that chowns stuff to the right user. Find
+ does weird things in the presence of !.
- -- Peter Palfrader <weasel@debian.org> Sat, 2 Feb 2008 15:13:17 +0100
+ -- Peter Palfrader <weasel@debian.org> Sun, 3 Feb 2008 18:17:16 +0100
tor (0.2.0.18-alpha-1) experimental; urgency=low
diff --git a/debian/tor.postinst b/debian/tor.postinst
index 70b14eec9a..7d607b6e68 100644
--- a/debian/tor.postinst
+++ b/debian/tor.postinst
@@ -39,15 +39,15 @@ for i in lib run log; do
fi
done
-find /var/lib/tor ! -user debian-tor -o ! -group debian-tor -print0 | xargs -0 --no-run-if-empty chown debian-tor:debian-tor
+find /var/lib/tor \( \( ! -user debian-tor \) -o \( ! -group debian-tor \) \) -print0 | xargs -0 --no-run-if-empty chown debian-tor:debian-tor
find /var/lib/tor -type d -print0 | xargs -0 --no-run-if-empty chmod 02700
find /var/lib/tor -type f -print0 | xargs -0 --no-run-if-empty chmod 00600
-find /var/run/tor ! -user debian-tor -o ! -group debian-tor -print0 | xargs -0 --no-run-if-empty chown debian-tor:debian-tor
+find /var/run/tor \( \( ! -user debian-tor \) -o \( ! -group debian-tor \) \) -print0 | xargs -0 --no-run-if-empty chown debian-tor:debian-tor
find /var/run/tor -type d -print0 | xargs -0 --no-run-if-empty chmod 02750
find /var/run/tor -type f -print0 | xargs -0 --no-run-if-empty chmod 00600
-find /var/log/tor ! -user debian-tor -o ! -group adm -print0 | xargs -0 --no-run-if-empty chown debian-tor:adm
+find /var/log/tor \( \( ! -user debian-tor \) -o \( ! -group adm \) \) -print0 | xargs -0 --no-run-if-empty chown debian-tor:adm
find /var/log/tor -type d -print0 | xargs -0 --no-run-if-empty chmod 02750
find /var/log/tor -type f -print0 | xargs -0 --no-run-if-empty chmod 00640