aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorPeter Palfrader <peter@palfrader.org>2008-07-07 11:27:59 +0000
committerPeter Palfrader <peter@palfrader.org>2008-07-07 11:27:59 +0000
commit57de86bae723e164022f3c984b47a0d4dac068cf (patch)
tree6228e9a91a4b399ee1ab9bd6ee4aa407d27da910 /debian
parent272165e659f113a9a78d05baff61a41dd9b60f33 (diff)
downloadtor-57de86bae723e164022f3c984b47a0d4dac068cf.tar.gz
tor-57de86bae723e164022f3c984b47a0d4dac068cf.zip
merge from 0.2.0.x: r15718: Warn the admin if the number of file descriptors on his system is tiny
svn:r15719
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog4
-rw-r--r--debian/tor.init24
2 files changed, 21 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index 2c9a953e8a..7ea6a5b287 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,10 @@
tor (0.2.1.0-unreleased-1) XXperimental; urgency=low
* trunk
+ * Warn the admin if the number of file descriptors on his system is
+ tiny.
- -- Peter Palfrader <weasel@debian.org> Wed, 19 Mar 2008 20:09:25 +0100
+ -- Peter Palfrader <weasel@debian.org> Mon, 07 Jul 2008 13:25:49 +0200
tor (0.2.0.28-rc-1) experimental; urgency=low
diff --git a/debian/tor.init b/debian/tor.init
index ea71e94bb2..aa8fa37fd9 100644
--- a/debian/tor.init
+++ b/debian/tor.init
@@ -28,14 +28,26 @@ ARGS=""
# Let's try to figure our some sane defaults:
if [ -r /proc/sys/fs/file-max ]; then
system_max=`cat /proc/sys/fs/file-max`
- if [ "$system_max" -gt "80000" ] ; then
- MAX_FILEDESCRIPTORS=32768
- elif [ "$system_max" -gt "40000" ] ; then
- MAX_FILEDESCRIPTORS=16384
- elif [ "$system_max" -gt "10000" ] ; then
- MAX_FILEDESCRIPTORS=8192
+ #if [ "$system_max" -gt "80000" ] ; then
+ #MAX_FILEDESCRIPTORS=32768
+ #elif [ "$system_max" -gt "40000" ] ; then
+ #MAX_FILEDESCRIPTORS=16384
+ #elif [ "$system_max" -gt "10000" ] ; then
+ #MAX_FILEDESCRIPTORS=8192
+ if 0; then
+ echo fo
else
MAX_FILEDESCRIPTORS=1024
+ cat << EOF
+
+Warning: Your system has very few filedescriptors available in total.
+
+Maybe you should try raising that by adding 'fs.file-max=100000' to your
+/etc/sysctl.conf file. Feel free to pick any number that you deem appropriate.
+Then run 'sysctl -p'. See /proc/sys/fs/file-max for the current value, and
+file-nr in the same directory for how many of those are used at the moment.
+
+EOF
fi
else
MAX_FILEDESCRIPTORS=8192