summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorPeter Palfrader <peter@palfrader.org>2008-03-11 14:17:29 +0000
committerPeter Palfrader <peter@palfrader.org>2008-03-11 14:17:29 +0000
commite1829bf8cd51e0b11c4333dbdffed896ce281c95 (patch)
tree64bcf36bb4ac9e4ecf7fc60f6d15e580cad814ce /debian/rules
parent2c66c7d1e059492b27e4ddae865fd22b3713fd40 (diff)
downloadtor-e1829bf8cd51e0b11c4333dbdffed896ce281c95.tar.gz
tor-e1829bf8cd51e0b11c4333dbdffed896ce281c95.zip
Build the debian package with openbsd malloc.
Build with --enable-openbsd-malloc, unless no-enable-openbsd-malloc is found in DEB_BUILD_OPTIONS. Hopefully this deals with some of the horrible memory fragmentation that glibc's malloc causes. svn:r13970
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index dc836cafc2..24d727175b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -53,6 +53,10 @@ CONF_OPTIONS =
ifneq (,$(findstring with-dmalloc,$(DEB_BUILD_OPTIONS)))
CONF_OPTIONS += --with-dmalloc
endif
+# inhibit building with --enable-openbsd-malloc
+ifeq (,$(findstring no-enable-openbsd-malloc,$(DEB_BUILD_OPTIONS)))
+ CONF_OPTIONS += --enable-openbsd-malloc
+endif
configure: patch-stamp
config.status: configure