aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorPeter Palfrader <peter@palfrader.org>2009-10-11 10:39:49 +0200
committerPeter Palfrader <peter@palfrader.org>2009-10-11 10:39:49 +0200
commit4cb31d27b551df552647c1450dc1d687df142f56 (patch)
tree8508fc1245ac8e6494a1f603b35d9c5aea9c9cb8 /debian/rules
parent51a3afd6ac2bd2f48165d834dcde01d2893ca4f1 (diff)
downloadtor-4cb31d27b551df552647c1450dc1d687df142f56.tar.gz
tor-4cb31d27b551df552647c1450dc1d687df142f56.zip
Ship debian source with src/test/test.h
Upstream failed to ship src/test/test.h. Ship it in debian/ and manually copy it in place during configure and clean up in clean. Let's not use the patch system as this will most likely be rectified by next release.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 9 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index d164d4c753..dc12c16943 100755
--- a/debian/rules
+++ b/debian/rules
@@ -66,6 +66,11 @@ endif
configure: patch-stamp
config.status: configure
+ # clean up test.h stuff. XXX - expected to no longer be needed after tor-0.2.2.4-alpha
+ rm -f src/test/test.h.orig
+ ! [ -e src/test/test.h ] || mv src/test/test.h src/test/test.h.orig
+ cp debian/src-test-test.h src/test/test.h
+
@if [ "$(LOCALHOST_IP)" != "127.0.0.1" ]; then echo; echo; echo; echo; echo; echo "######################################################################"; echo "WARNING: This system does not think localhost is 127.0.0.1. Will ignore result of testsuite. Please fix your system/chroot."; echo "######################################################################"; echo; echo; echo; echo; echo "Note: 'getent hosts localhost' should return '127.0.0.1 localhost'"; echo; fi
dh_testdir
CFLAGS="$(CFLAGS)" ./configure \
@@ -135,6 +140,10 @@ clean: unpatch
[ ! -f Makefile ] || $(MAKE) distclean
+ # clean up test.h stuff. XXX - expected to no longer be needed after tor-0.2.2.4-alpha
+ rm -f src/test/test.h
+ ! [ -e src/test/test.h.orig ] || mv src/test/test.h.orig src/test/test.h
+
# Normally the .deb wouldn't ship with a ../.git
if [ -d .git ] && which git >/dev/null; then \
echo "\"`git rev-parse --short=16 HEAD`\"" > "debian/micro-revision.i" ; \