summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2010-02-25 15:58:55 -0500
committerNick Mathewson <nickm@torproject.org>2010-02-25 16:09:10 -0500
commit6fa8dacb97587707156507aa35141e414fc284bb (patch)
treed51c20ce8b0e65a0c17aff72a119c2b2686d1496 /configure.in
parent8b93dacbcfbca7b4653f7a9b727bdc209aff1e7c (diff)
downloadtor-6fa8dacb97587707156507aa35141e414fc284bb.tar.gz
tor-6fa8dacb97587707156507aa35141e414fc284bb.zip
Add a tor_asprintf() function, and use it in a couple of places.
asprintf() is a GNU extension that some BSDs have picked up: it does a printf into a newly allocated chunk of RAM. Our tor_asprintf() differs from standard asprintf() in that: - Like our other malloc functions, it asserts on OOM. - It works on windows. - It always sets its return-field.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index e045c08b35..e948503113 100644
--- a/configure.in
+++ b/configure.in
@@ -189,7 +189,7 @@ dnl -------------------------------------------------------------------
dnl Check for functions before libevent, since libevent-1.2 apparently
dnl exports strlcpy without defining it in a header.
-AC_CHECK_FUNCS(gettimeofday ftime socketpair uname inet_aton strptime getrlimit strlcat strlcpy strtoull getaddrinfo localtime_r gmtime_r memmem strtok_r writev readv flock prctl)
+AC_CHECK_FUNCS(gettimeofday ftime socketpair uname inet_aton strptime getrlimit strlcat strlcpy strtoull getaddrinfo localtime_r gmtime_r memmem strtok_r writev readv flock prctl vasprintf)
using_custom_malloc=no
if test x$enable_openbsd_malloc = xyes ; then