summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2009-01-07 21:05:02 +0000
committerNick Mathewson <nickm@torproject.org>2009-01-07 21:05:02 +0000
commita6504cdea7680621431c2920391e2a14a052c14e (patch)
tree0257c2f186d99b50de9fd4bac10c12da32c3be38 /configure.in
parentc123163043e42668c3597298e14d25607a2d4623 (diff)
downloadtor-a6504cdea7680621431c2920391e2a14a052c14e.tar.gz
tor-a6504cdea7680621431c2920391e2a14a052c14e.zip
Check that Libevent header version matches Libevent library version.
Unfortunately, old Libevents don't _put_ a version in their headers, so this can get a little tricky. Fortunately, the only binary-compatibility issue we care about is the size of struct event. Even more fortunately, Libevent 2.0 will let us keep binary compatiblity forever by letting us decouple ourselves from the structs, if we like. svn:r18014
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index aa59e776a5..8cd4428853 100644
--- a/configure.in
+++ b/configure.in
@@ -264,6 +264,10 @@ LIBS="-levent $TOR_LIB_WS32 $LIBS"
LDFLAGS="$TOR_LDFLAGS_libevent $LDFLAGS"
CPPFLAGS="$TOR_CPPFLAGS_libevent $CPPFLAGS"
AC_CHECK_FUNCS(event_get_version event_get_method event_set_log_callback)
+AC_CHECK_MEMBERS([struct event.min_heap_idx], , ,
+[#include <event.h>
+])
+
LIBS="$save_LIBS"
LDFLAGS="$save_LDFLAGS"
CPPFLAGS="$save_CPPFLAGS"