summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2012-06-11 12:22:48 -0400
committerNick Mathewson <nickm@torproject.org>2012-06-11 12:23:42 -0400
commit4717951cfaa7bc97ace35b6a542495680844f407 (patch)
tree1a92dfc3ed83c614d23e4394daf2122525800c81 /configure.in
parentebaaa4834f803015e68d348f330fcef88de34a92 (diff)
downloadtor-4717951cfaa7bc97ace35b6a542495680844f407.tar.gz
tor-4717951cfaa7bc97ace35b6a542495680844f407.zip
Do not try to use -pie on windows; it appears to break badly and weirdly
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 7167ca9366..051c924a9d 100644
--- a/configure.in
+++ b/configure.in
@@ -566,9 +566,11 @@ if test x$enable_gcc_hardening != xno; then
TOR_CHECK_CFLAGS(-fstack-protector-all)
TOR_CHECK_CFLAGS(-Wstack-protector)
TOR_CHECK_CFLAGS(-fwrapv)
- TOR_CHECK_CFLAGS(-fPIE)
TOR_CHECK_CFLAGS(--param ssp-buffer-size=1)
- TOR_CHECK_LDFLAGS(-pie, "$all_ldflags_for_check", "$all_libs_for_check")
+ if test "$bwin32" = "false"; then
+ TOR_CHECK_CFLAGS(-fPIE)
+ TOR_CHECK_LDFLAGS(-pie, "$all_ldflags_for_check", "$all_libs_for_check")
+ fi
fi
if test x$enable_linker_hardening != xno; then