summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2009-07-07 14:26:50 -0400
committerNick Mathewson <nickm@torproject.org>2009-07-07 14:26:50 -0400
commit041a7b989630c846fa087628145920198da001f6 (patch)
treeed29c7fcd22f79a5192c6f136ca6ecb1b9bc2548 /configure.in
parent1c1b22391061613f875d88daf2f54d083ff929ec (diff)
parentc0b6cb132baaf9cf259bfb09e14c1128d7abc9d6 (diff)
downloadtor-041a7b989630c846fa087628145920198da001f6.tar.gz
tor-041a7b989630c846fa087628145920198da001f6.zip
Merge commit 'karsten/entrystats-master'
Conflicts: ChangeLog configure.in src/or/config.c src/or/or.h
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 10b05aeffb..0f6ed80657 100644
--- a/configure.in
+++ b/configure.in
@@ -106,6 +106,13 @@ if test "$enable_buffer_stats" = "yes"; then
AC_DEFINE(ENABLE_BUFFER_STATS, 1, [Defined if we try to collect buffer statistics])
fi
+AC_ARG_ENABLE(entry-stats,
+ AS_HELP_STRING(--enable-entry-stats, enable code for entry guards to collect per-country statistics))
+
+if test "$enable_entry_stats" = "yes"; then
+ AC_DEFINE(ENABLE_ENTRY_STATS, 1, [Defined if we try to collect per-country statistics])
+fi
+
AC_ARG_ENABLE(gcc-warnings,
AS_HELP_STRING(--enable-gcc-warnings, enable verbose warnings))