summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPeter Palfrader <peter@palfrader.org>2008-06-02 15:09:24 +0000
committerPeter Palfrader <peter@palfrader.org>2008-06-02 15:09:24 +0000
commitf1f8bf5d7297a82832b94604e3086a6c43809aa8 (patch)
tree0965f4e485aabd98227fec5c2901fbb033ddebfe /configure.in
parent716558a6a1c7550d06bed91fd2369ee76b8aef0a (diff)
downloadtor-f1f8bf5d7297a82832b94604e3086a6c43809aa8.tar.gz
tor-f1f8bf5d7297a82832b94604e3086a6c43809aa8.zip
Add a configure switch to enable instrument downloads.
svn:r14898
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 9752553406..d33da17e6e 100644
--- a/configure.in
+++ b/configure.in
@@ -42,6 +42,8 @@ AC_ARG_ENABLE(buf-freelists,
AS_HELP_STRING(--disable-buf-freelists, disable freelists for buffer RAM))
AC_ARG_ENABLE(openbsd-malloc,
AS_HELP_STRING(--enable-openbsd-malloc, Use malloc code from openbsd. Linux only))
+AC_ARG_ENABLE(instrument-downloads,
+ AS_HELP_STRING(--enable-instrument-downloads, Instrument downloads of directory resources etc.))
if test x$enable_cell_pool != xno; then
@@ -53,6 +55,10 @@ if test x$enable_buf_freelists != xno; then
[Defined if we try to use freelists for buffer RAM chunks])
fi
AM_CONDITIONAL(USE_OPENBSD_MALLOC, test x$enable_openbsd_malloc = xyes)
+if test x$enable_instrument_downloads == xyes; then
+ AC_DEFINE(INSTRUMENT_DOWNLOADS, 1,
+ [Defined if we want to keep track of how much of each kind of resource we download.])
+fi
AC_ARG_ENABLE(transparent,
AS_HELP_STRING(--disable-transparent, disable transparent proxy support),