summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSebastian Hahn <sebastian@torproject.org>2010-10-15 02:46:19 +0200
committerSebastian Hahn <sebastian@torproject.org>2010-10-15 02:46:19 +0200
commit01cde8dbf3489607a89c08b3602716d8e3b60753 (patch)
treeeced5cc054cab5eda0ae61881ae17f63aa717534 /configure.in
parent9bed40eb103af93e0eb62c8cef2610e432426a5d (diff)
downloadtor-01cde8dbf3489607a89c08b3602716d8e3b60753.tar.gz
tor-01cde8dbf3489607a89c08b3602716d8e3b60753.zip
Raise libevent version needed for bufferevents
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 35f1e24b29..5ddaf3f90f 100644
--- a/configure.in
+++ b/configure.in
@@ -352,7 +352,7 @@ dnl This isn't the best test for Libevent 2.0.3-alpha. Once it's released,
dnl we can do much better.
if test "$enable_bufferevents" = "yes" ; then
if test "$ac_cv_header_event2_bufferevent_ssl_h" != "yes" ; then
- AC_MSG_ERROR([You've asked for bufferevent support, but you're using a version of Libevent without SSL support. This won't work. We need Libevent 2.0.7-rc or later, and you don't seem to even have Libevent 2.0.3-alpha.])
+ AC_MSG_ERROR([You've asked for bufferevent support, but you're using a version of Libevent without SSL support. This won't work. We need Libevent 2.0.8-rc or later, and you don't seem to even have Libevent 2.0.3-alpha.])
else
CPPFLAGS="$CPPFLAGS $TOR_CPPFLAGS_libevent"
@@ -375,7 +375,7 @@ int x = 1;
AC_MSG_CHECKING([whether Libevent is new enough for bufferevents])
AC_COMPILE_IFELSE([AC_LANG_SOURCE([
#include <event2/event.h>
-#if !defined(LIBEVENT_VERSION_NUMBER) || LIBEVENT_VERSION_NUMBER < 0x02000700
+#if !defined(LIBEVENT_VERSION_NUMBER) || LIBEVENT_VERSION_NUMBER < 0x02000800
#error
int x = y(zz);
#else
@@ -383,7 +383,7 @@ int x = 1;
#endif
])], [ AC_MSG_RESULT([yes]) ],
[ AC_MSG_RESULT([no])
- AC_MSG_ERROR([Libevent does not seem new enough to support bufferevents. We require 2.0.7-rc or later]) ] )
+ AC_MSG_ERROR([Libevent does not seem new enough to support bufferevents. We require 2.0.8-rc or later]) ] )
fi
fi
fi