summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPeter Palfrader <peter@palfrader.org>2005-09-10 20:44:05 +0000
committerPeter Palfrader <peter@palfrader.org>2005-09-10 20:44:05 +0000
commit0ceab199b09ad9a13f4d6a0b79f96d6d6308cfd1 (patch)
tree3cfa16c5dd29e70568c65ffcdd1c7eaa0b246dc6 /configure.in
parentb0a5ba424881c8e1025bbe0d6a928e7b05aa17ae (diff)
downloadtor-0ceab199b09ad9a13f4d6a0b79f96d6d6308cfd1.tar.gz
tor-0ceab199b09ad9a13f4d6a0b79f96d6d6308cfd1.zip
Do not use unaligned access on some more archs
svn:r4992
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index f34e3213ea..f3843f8e6a 100644
--- a/configure.in
+++ b/configure.in
@@ -368,6 +368,14 @@ case $host in
ia64-*-* | arm-*-* | sparc-*-* )
tor_cv_unaligned_ok=no
;;
+ # On the following architectures unaligned access works, but is not done in
+ # hardware. This means that when you try to do unaligned access the kernel
+ # gets to sort out an exception and then work around to somehow make your
+ # reqest work, which is quite expensive. Therefore it's probably better to
+ # not even do it.
+ alpha-*-* | mips-*-* | mipsel-*-* )
+ tor_cv_unaligned_ok=no
+ ;;
*)
AC_CACHE_CHECK([whether unaligned int access is allowed], tor_cv_unaligned_ok,
[AC_RUN_IFELSE([AC_LANG_SOURCE(