summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSebastian Hahn <sebastian@torproject.org>2010-10-11 17:08:42 +0200
committerSebastian Hahn <sebastian@torproject.org>2010-10-11 17:08:42 +0200
commit50d77ad4b62c7b6fee1ed60ea5bc138567149d67 (patch)
tree96fc99f38bcd4132168c2ac33ebe40c157b2d271 /configure.in
parent544a8afe5afe2f7f682d8bc632c115e91ba3ad46 (diff)
downloadtor-50d77ad4b62c7b6fee1ed60ea5bc138567149d67.tar.gz
tor-50d77ad4b62c7b6fee1ed60ea5bc138567149d67.zip
Fix the new warnings during autogen.sh
Follow-up fix to 3d6e2830876c for configure.in additions in master that weren't in maint-0.2.2
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 4f4b9619cf..ae5ed207ea 100644
--- a/configure.in
+++ b/configure.in
@@ -359,7 +359,7 @@ if test "$enable_bufferevents" = "yes" ; then
# Check for the right version. First see if version detection works.
AC_MSG_CHECKING([whether we can detect the Libevent version])
- AC_COMPILE_IFELSE([
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([
#include <event2/event.h>
#if !defined(LIBEVENT_VERSION_NUMBER) || LIBEVENT_VERSION_NUMBER < 10
#error
@@ -367,13 +367,13 @@ int x = y(zz);
#else
int x = 1;
#endif
- ], [event_version_number_works=yes; AC_MSG_RESULT([yes]) ],
+ ])], [event_version_number_works=yes; AC_MSG_RESULT([yes]) ],
[event_version_number_works=no; AC_MSG_RESULT([no])])
if test "$event_version_number_works" != 'yes'; then
AC_MSG_WARN([Version detection on Libevent seems broken. Your Libevent installation is probably screwed up or very old.])
else
AC_MSG_CHECKING([whether Libevent is new enough for bufferevents])
- AC_COMPILE_IFELSE([
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([
#include <event2/event.h>
#if !defined(LIBEVENT_VERSION_NUMBER) || LIBEVENT_VERSION_NUMBER < 0x02000700
#error
@@ -381,7 +381,7 @@ int x = y(zz);
#else
int x = 1;
#endif
- ], [ AC_MSG_RESULT([yes]) ],
+ ])], [ AC_MSG_RESULT([yes]) ],
[ AC_MSG_RESULT([no])
AC_MSG_ERROR([Libevent does not seem new enough to support bufferevents. We require 2.0.7-rc or later]) ] )
fi